Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

Installation of LabVIEW RunTime on a Raspberry Pi 2

Solved!
Go to solution

Hello,

I'm new Raspberry Pi user. I'm trying to deply LabIVEW application on a Rapsberry I've bought years ago, but impossible (installation always failed). 

My Rasberry is OK (all is updated). I think it's a compatibility problem...

I work with LabVIEW 2021 and a Raspberry Pi 2. LINX is properly installed, it's running with an arduino uno. When I try to install, I've a message: only LV14 can be installed. I've tried with different versions, same result... 

How can I proceed to use my raspberry with LabVIEW?

Thank you per advance!

Regards,

Francis M
0 Kudos
Message 1 of 5
(1,889 Views)

Hi Francis M,

 

I think it's likely that the host installation is not correct in some way.  How did you install?  Via VI Package Manager? 

 

I suspect you'd have better luck using the LabVIEW 2021 Community Edition installer since it has the Hobbyist/LINX toolkit pre-installed.

 

Regards,

Ken

Message 2 of 5
(1,756 Views)

Hi Ken,

 

Thank you for your feedback. I've installed LINX as usual with VIPM. It's seems to be running, no problem with my arduino. I suspect a compatibility problem, but impossible to find a table or a specification: which LabVIEW version compatible with which Raspi HW version?

 

I will try with communit edition, I've just to find time to intall it...

 

Regads,

Francis M
0 Kudos
Message 3 of 5
(1,680 Views)
Solution
Accepted by topic author Cisco

The problem is that you installed the wrong package. The Linx Toolkit only works with LabVIEW 2014 properly.

If you have LabVIEW 2020 or newer you need to install the LabVIEW Hobbyist Toolkit instead.

 

And the Linx Toolkit does some deep modifications to your LabVIEW installation that are difficult to unravel and an uninstall of it is not guaranteed to make it all back to normal. So it is better to completely reinstall LabVIEW and then install the Hobbyist Toolkit on top.

Rolf Kalbermatter
My Blog
Message 4 of 5
(1,530 Views)

Hello,

Thank you Rolf for the explanation. I had installed Hobbyist toolkit too, but I'm not sure of the order of all my installation. I will try again, starting from 0 to be sure of I do.

My first question seems to be solved: LV21 application can run on a Raspi 2B.

Thank you all for the support!

Francis M
0 Kudos
Message 5 of 5
(1,472 Views)