Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

Firmware Wizard fails to generate Arduino library

Go to solution



I am attempt to get started with LINX on LabVIEW professional 2020 and an Arduino Micro.


When attempting to generate firmware for the Arduino Micro via the wizard, the output libraries fail to get generated.


When pressing the "generate" button, no errors are reported, and the status reports as "done", but no file are added to the destination directory. When pressing 'save' an error is reported stating that no libraries can be found.



Things I've tried so far:

- I ensured that there were full read/write permissions to the Arduino program files directory

- I started with Arduino IDE v1.8.3 (most current). I then downgraded to v1.0.6. this changed behavior in that the IDE was launched during the cmd instruction from the wizard VI, but still no output files.

- I attempted to manually pull together the source files from within the LINX source directory and compile in the Arduino IDE. I'm still getting many linking errors, but could revisit this if no other solution presents itself

- I started to debug the firmware wizard VI, and found a possible typo in the generation of the destination path, but that seems unlikely as then it would be failing for everyone that tries to use the LINX plugin, and I haven't see any complaints of this nature. More likely that I'm misunderstanding the code.





So my question at this point is if anyone has a working firmware wiring project they can share for an Arduino micro, or has other suggestions for getting past this issue.






0 Kudos
Message 1 of 5

Update - Did find some log files, which indicate an issue with the COM connection. I am able to connect to this Arduino through the arduino IDE however. investigating this now.


avrdude_ard.exe: Version 6.0.1, compiled on Mar 30 2015 at 14:56:06
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "avrdude_ard.conf"

Using Port : COM4
Using Programmer : avr109
Overriding Baud Rate : 57600
avrdude_ard.exe: ser_open(): can't open device "\\.\COM4": The system cannot find the file specified.

avrdude_ard.exe: ser_send(): write error: sorry no info avail

0 Kudos
Message 2 of 5
Accepted by topic author BFVespone

Not sure what is wrong with the firmware wizard, but if anyone runs into the same issue, attached is a compilable sketch containing the cpp and h files needed to get the Micro working.

0 Kudos
Message 3 of 5

Hi BFVesone!


Thanks for documenting your issue here, i think i am currently having a similar one:


The strange thing is that my whole setup worked brilliantly until my arduino leonardo broke and i had to get a new one. After that i always got the error code 5003 "cannot connect to arduino" even with the example from MakerHub.


I am now searching since 2 days and found your post about the failure of gererating the arduino library. I checked and its the same for me! The wizard tells Done! but nothing happens.


Since i am not so into the arduino i dont really understand how you fixed this issue with the sketch you attached. Would you mind explaining the procedure here?


Many thanks!


0 Kudos
Message 4 of 5


I've came with the same problem. I'm using arduino Leonardo and firmware wizard return no error and does nothing. 

Clicking on "View Log" says: 

" avrdude_ard.exe: ser_open(): can't open device "

Same issue occurs on my laptot and desktop.

Does anyone know how to solve this?

0 Kudos
Message 5 of 5