Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

Failing connection using LINX to connect to Arduino

Hello, 

 

I'm currently having issues with getting an Arduino Leonardo to properly connect and function via the Linx "Open vi" control. (File: "DOESNT WORK...") Sometimes upon running the program the Linx spits out an 5003 error which, as far as I can tell, is just a communication failure. Other times, the link enters the while loop without issue, but then boolean controls that follow in the Linx chain have incredibly slow response times (10-20s, if they respond at all). The NI DAQ that also exists in this vi often times out and can't keep with up the software, causing a failure of a different kind but which is surely related. I've tried various combinations of acquisition mode, # of samples to read, and sampling rate, to try and ease the load on it but nothing has helped. 

 

I've tried several time to follow the Tools -> MakerHub -> Linx -> Linx Firmware Wizard and re-upload the Arduino firmware, but this also leads to a connection failure and I don't think it helps anything. 

 

I have another vi ("WORKS...") that contains only the Linx chain (reading off the same COM port) and DAQ assistant (and associated items) that works perfectly, with no Arduino connection or DAQ issues to speak of and very quick boolean control response time. 

 

Why would the other vi work without issue but when I try to run this one it rarely completes the connection, let alone functions as a vi properly? Any advice to sort it out? 

 

Also I'm rather new to LV and almost certainly haven't done everything in this vi as efficiently and cleanly as possible, so if you see something blatant that could be better please point it out. However, the Linx and DAQ are my main concerns. 

 

Devices/systems are: LabView 2020, cDAQ-9171, Arduino Uno

 

Thanks in advance, 

Drake 

0 Kudos
Message 1 of 1
(89 Views)