Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

Error 59: HTTP-Connection "Raspberry Pi 4 Model B" -> "mDNS" doesn't work!

Hello everybody!

can anyone help me solve my mDNS-Problem on Raspberry Pi?

I tried to send an http-Request in LabVIEW deployed on my Raspberry Pi to my Sensor, which provides a mDNS-Service.

But it throws an Error 59, as shown below.
(Although on the right you can see, that ping works fine with DNS and mDNS.)

Screenshot (above: DNS works! below: mDNS doesn't work!)Screenshot (above: DNS works! below: mDNS doesn't work!)

LINX Target Configuration of my Rasberry Pi 4 Model B -> Installed Version: 20.0.0.-4

As you can see this error only occurs, when i run it on "raspberrypi".
The Error doesn't occur, when i run it on "My Computer".

does anyone know, how to troubleshoot?
thanks and greetings

0 Kudos
Message 1 of 2

I wrote my own mDNS client. At that point, you can replace the hostname.local with the IP address and everything should work.

mDNS Query.png

0 Kudos
Message 2 of 2