Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

Blinking LED with Arduino/LINX

I'm running a simple blink led program on Labview using LINX. I'm using the built-in 'L' LED on Arduino Uno, which is digital I/O pin 13.

When I run the program for the first time, it runs fine and the led is turning on and off by the control in the program.


But when I stop the program and run it again, it doesn't run. The 'L' LED continuously stays ON, the RX blinks very fast for a second, and the TX led does not blink at all. And then the control button on the program does nothing, the L LED stays on continuously. Sometimes the error boxes, of which the pictures I've attached, pop up, and sometimes they don't. 

However, when I load the LINX firmware once again, the program again runs fine once and then doesn't run for the second time.


This doesn't happen when I open the Blink(Simple) example. I am able to run it multiple times without loading the LINX firmware again. 

There are no other VIs open on my PC. 


Do I have to load the firmware every time I run a program? That doesn't make sense to me. 


I've attached the VI to this question. 


sarwatsarfaraz_0-1659423646355.png sarwatsarfaraz_1-1659424266977.png



0 Kudos
Message 1 of 3

Well, that should not be happening. You do not need to flash firmware everytime.


Are you using the stop button in order to dataflow close the LINX communication and then releasing the COM port or are you just hitting abort?

That happened to me once.

if that does not work, try to upload from arduino IDE.

when that happens, try to close LabVIEW, removing USB, then plugging it back on and starting LabVIEW. This way you can verify if it is a COM problem or other LabVIEW LINX problem. 

if it is a LINX problem, then try to uninstall from VIPM, then reinstall, always rebooting your application.

Those are the things i would try.

EDIT: also try to reset your arduino UNO with the reset button

Jorge Augusto Pessatto Mondadori, PhD
Sistema Fiep
Message 2 of 3

Thanks.  Reinstalling LINX via VIPM seemed to fix the problem.

0 Kudos
Message 3 of 3