Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

Arduino Uno and MPU6050 Error 5001 problem

Hello everyone, when I run a program using Arduino Uno and MPU6050 sensor, I get the following error. The same program was running fine yesterday. Thanks in advance for your help. I am attaching the block diagram below.

Download All
0 Kudos
Message 1 of 4
(148 Views)

Have you rebooted your PC and tried again?  If the serial port is not available this may occur.

 

If that doesn't work, what changed between when it worked and when it doesn't?  Something had to have changed until it is an intermittent issue which always existed.

David Wilt
The New Standard LLC
0 Kudos
Message 2 of 4
(125 Views)

I didn't make any changes, I just configured my new arduino nano from LINX Firmware Wizard and then I started having such a problem.

0 Kudos
Message 3 of 4
(118 Views)

You did not confirm you fully rebooted your PC.  If you do not properly release the serial port it will be unavailable until you reboot your PC 

 

Also, you said you configured a "new" nano so you are saying when it was working you were using a different nano?  What does the other nano do now?

 

I don't use these devices so I can't help with specific details.  I am just trying to help you isolate the issue.

David Wilt
The New Standard LLC
0 Kudos
Message 4 of 4
(84 Views)