High-Speed Digitizers

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem of using niScope.lib in VS2015

Solved!
Go to solution
Solution
Accepted by topic author wsxxdzlj

Hi Ancher,

 

I can give you my solution here:

  I add the file "legacy_stdio_definitions.lib" to "Linker -> Input -> Additional Dependencies". Then, the problem is solved. I use Win10, VS2015 and my software is released in 64-bit.

 

It works on my software. I am not sure whether it is still work for you. If you try my method, please give me your feedback. Thanks.

0 Kudos
Message 11 of 15
(2,404 Views)

Hello Balexand,

 

My version of niScope_32.dll is 4.3.0.49152  / 4.3.0f0, it's OK.

With your library, it compile fine, thanks a lot for this.

 

I don't use LabWindows/CVI, so I yhink thaht the kind of trouble you feel doesn't append to me.

 

Thanks again, this "special" release allows me to work until the next release.

 

Regards.

 

0 Kudos
Message 12 of 15
(2,391 Views)

Hello wsxxdzlj,

 

I don't tried your solution, with the library delivered by Balexand I have linked without any error.

Anyway, thanks for your solution, it can be very useful for some other people.

 

Regards.

 

 

0 Kudos
Message 13 of 15
(2,388 Views)

Hi Nathan,

Now NI-SCOPE version is 16.0. However, this issue is still not solved. Is there any news about solving this issue?

0 Kudos
Message 14 of 15
(1,726 Views)

Changes that went into NI-SCOPE 16.0 were mostly just for LabVIEW 2016 support.  You may notice that niScope_32.dll is still the same version (4.3.0f0).

 

We are aware that this issue is still open.  It is being tracked as Bug ID 546023.

0 Kudos
Message 15 of 15
(1,708 Views)