High-Speed Digitizers

cancel
Showing results for 
Search instead for 
Did you mean: 

PXI 5152 in LV 7.0

Hi,..I recently purchased a PXI 5152 digitiser. The driver CD had NI Scope 3.4 which, when installed worked fine. But it also installed NI DAQ MX 8.5 (min. requirement) and removed my older version of DAQMx.. This new version DAQMx 8.5 does not support LV7.0. (My APE is LabVIEW 7.0.) So I can't get any DAQMx I/0 blocks from LabVIEW.
 
 
When I uninstalled DAQMx 8.5, NI Scope 3.4 also got removed. Then I rolled back to my old config of DAQ and Scope 2.5. But now my digitiser is not recognised.
 
Where can I get a 5152 digitiser driver(NI SCOPE) that works for LV7.0 also.(I was unable to find one from NI website. They all needed LV7.1 or later)
 
I am using a PXi system with PXI - 8175 controller.

One more thing..The newer versions of NI SCOPE that support PXI 5152 also need newer versions of DAQMx that does not support LV7.0.

It would be helpful is some one can some one point me to the latest version of DAQMx that supports LV7.0 and a corresponding NI SCOPE version that supports 5152

I was unable to identify a correct combination that worked for me!..

 
0 Kudos
Message 1 of 8
(7,802 Views)

Hello,

The latest version of DAQmx compatible with Labview 7.0 is DAQmx 8.1.  The latest version of NI-Scope compatible with Labview 7.0 is NI-Scope 3.0.  However, there is a bigger issue here related to the 5152 device. 

The NI 5152 (PXI version) is supported on NI-Scope 3.2 or later.  The NI-Scope 3.2 requires Labview 7.1 or later.  Thus the current setup of Labview 7.0 paired with the 5152 is not supported.  I am sorry for the inconvenience.  You are basically looking at upgrading to newer version of Labview or selecting another digitizer device supported by the NI-Scope 3.0 driver.  Please give me some feedback so I can help further guide you to a solution.  If you are interested in reviewing the information I have posted, please view the attached links.

NI-DAQ & LabVIEW Version Compatibility (for Windows)

NI-SCOPE 3.0 Readme File

NI-SCOPE 3.2 Readme File

 

Samantha
National Instruments
Applications Engineer
0 Kudos
Message 2 of 8
(7,784 Views)
Thank you very much for the information. 🙂

Changing the digitiser is not an option for me.

I had tried using SCOPE 3.4 and it worked fine(I tried with the soft front panels). But I need the DAQMx blocks for other vi's in my application.
Is there any way in which I can add support to PXI5252 onto an older version of SCOPE(say 3.0 or 2.5) so that I can use my current setup.
 I am asking if there is any way to patch the older version of NI SCOPE to recognise the 5152 device also.

Also, will NI SCOPE 3.2 work with DAQMx 8.1?..or does it need a later version of DAQMx ?


Message Edited by jj@IIT on 03-06-2008 11:37 PM
0 Kudos
Message 3 of 8
(7,781 Views)
Hello jj,
 
I am sorry for the inconvenience, but we do not have a patch for your setup.  I understand that you have gotten the Soft Front Panel to work with the  3.4 version.  However, you will not be able to get the VIs related to the NI-Scope driver in Labview 7.0 and interfacing with the 5152. 
 
You asked what version of DAQmx would work with the NI-Scope 3.2 version.  The 3.2 version works with DAQmx driver 8.3 and later ... this DAQmx version is not supported by 7.0.
 
What other hardware do you have in your PXI system?  I want to see if upgrading your version of Labview in an issue or limitation.  Please give me some feedback.  At this time, I think it would be best to consider upgrading to a newer version of Labview, since you stated that changing the digitizer is not an option.
Samantha
National Instruments
Applications Engineer
0 Kudos
Message 4 of 8
(7,755 Views)
Thanks for the effort and help. I am now thinking of updating my LabVIEW version.
 Please take a look at my hardware setup given below, and advice me on which version of LabVIEW fits the bill.

PXI 1002 Chasis
PXI 8175 Controller: 800MHz,128MB Ram running Windows 2000.
PXI 5152 digitiser
PXI 6025E Multifunction DAQ
PXI 6602 Timing I/O

As you can see, my base PXI controller and chasis are a bit old. I don't have an option of changing them.Please comment.
0 Kudos
Message 5 of 8
(7,743 Views)

Hello,

I just saw that you have a duplicate post.

Forum Post: How to get PXI 5152 working in LabVIEW 7.0

It looks like the PXI 5152 digitizer, PXI 6025E Multifunction DAQ, and PXI 6602 Timing I/O will not have a compatibility issue with a newer version of LabVIEW.  The driver on the controller will just need to be updated.  However as Jaime noted, I do not think that your current controller meets LabVIEW system requirements needed.


Message Edited by samantham on 03-12-2008 11:42 AM
Samantha
National Instruments
Applications Engineer
0 Kudos
Message 6 of 8
(7,721 Views)
I updated my LabVIEW version to 8.0. Now I can control the scope as well as the counter from my Vi. LV 8 needs minimum of 256MB ram. My controller has only 128 MB. The system is very slow while running LV8 now(i expected that!!).
 Is there any way that I can upgrade the ram, like I do in a normal computer(by adding another SIMM in the slot)


Message Edited by jj@IIT on 03-12-2008 10:06 PM
0 Kudos
Message 7 of 8
(7,709 Views)
Howdy jj,

Yep, you can upgrade the RAM on your PXI-8175 controller. Please refer to this KnowledgeBase article on RAM upgrades for the 817x series of embedded controllers..
Warm regards,

pBerg
0 Kudos
Message 8 of 8
(7,696 Views)