High-Speed Digitizers

cancel
Showing results for 
Search instead for 
Did you mean: 

No data presented on "Horizontal Zoom" section of Ni-Scope

Solved!
Go to solution

set uo (cont)

Download All
0 Kudos
Message 11 of 17
(4,376 Views)
Solution
Accepted by topic author digigdawg

Unfortunately I don't have a USB-5133 so I can't test this with a physical device, but I haven't been able to reproduce the issue with a simulated device.  I know that doesn't really help the situation since you aren't encountering the issue with simulated devices either.

 

However, I do note that in your screenshots somehow you have channels 0 and channel 1 swapped from what is normally seen -- i.e., channel 0 is in the right dropdown and channel 1 is in the left dropdown.  Normally such a configuration isn't possible unless a device has more than 2 channels, since by default channel 0 is in the left dropdown and you can never have the same channel selected in both dropdowns simultaneously, thereby eliminating the possibility of swapping them.  Of course from your image we see that this has occurred, so... yeah...

 

It is possible you have a corrupted configuration file for the device saved to the hard drive.  If I recall correctly, upon upgrading (or downgrading) NI-SCOPE versions,the config files are not automatically deleted from the hard drive so that could potentially explain why we see this behavior even in 14.1 which had numerous fixes to the horizontal zoom capabilities.  At this point I really only have a couple of suggestions.

 

  1. Assuming your XP version is 32-bit, browse to C:\Program Files\IVI Foundation\IVI\Drivers\niScope  and attach the ScpSFPCfg_USBSCOPE.h5 file you should find there to this forum post so we can see if loading the file with a simulated device of the same name exhibits the same behavior.
  2. After ensuring that NI-SCOPE SFP is closed, delete or rename the ScpSFPCfg_USBSCOPE.h5 file.  The file is saved automatically upon SFP exit, so you want to make sure the SFP isn't open when deleting it or else it will show back up with the same settings.
  3. Open the SFP, click on Horizontal Zoom, and cross your fingers.
  4. If it works, try turning off horizontal zoom and then reconfiguring your device to the way you had it previously and then reenabling the zoom feature.
  5. If neither 3 nor 4 work, try resizing the area being zoomed by clicking on either the left or right red line and expanding or contracting the zoomed area to see if that forces a refresh of the data.

If deleting the configuration file doesn't fix the issue, it would be nice if someone else could test this on real hardware.

 

Drew

Message 12 of 17
(4,353 Views)

Looks like deleting the .h5 file fixxed the issue!  I have included it for future reference.  Thank you very much for your help in resolving this issue!!!

0 Kudos
Message 13 of 17
(4,341 Views)

more

 

might have to erase the ".doc" on file name.  Wouldnt let me send as original file.

0 Kudos
Message 14 of 17
(4,340 Views)

Excellent 🙂

0 Kudos
Message 15 of 17
(4,336 Views)

Thanks Drew!

former NIer
Austin Walton, Engineering Manager
0 Kudos
Message 16 of 17
(4,294 Views)

Same issue faced with Scope update from v14 to v15. This method works. Thanks.

0 Kudos
Message 17 of 17
(2,151 Views)