High-Speed Digitizers

cancel
Showing results for 
Search instead for 
Did you mean: 

NI Scope Soft Front Panel fails to Load

Solved!
Go to solution

Hi,

I've been using the NI Scope Soft Front Panel with my NI USB 5132 for some time now successfully. However, recently it stopped working entirely - seems to load for a bit then fails before even opening the screen. The same thing happens in MAX. I did all the critical updates, uninstalled and then reinstalled NI Scope, uninstalled Labview (the one thing I had changed after the last time I know it worked successfully), and checked that the nitaglv.dll library was in the correct place as per this post: http://digital.ni.com/public.nsf/allkb/63739991438EC593862579C6007301EC

 

So far nothing's worked. I have NI SCOPE 4.0 and NI-VISA 5.3.0 installed, and the computer was able to successfully see the USB 5132 digitizer in MAX after reinstalling NI Scope, although the soft front panel still wouldn't load and doing test panel in MAX also doesn't work.

 

I've attached a picture of the loading screen before it goes away if that might provide any clues...

 

Suggestions?

0 Kudos
Message 1 of 18
(9,744 Views)

Hi malagon,

 

What version of LabVIEW are you currently using? Were you using the same version of NI-SCOPE and NI-VISA when the soft front panel was working?
Do you think the changes you made in LabVIEW are what caused this?

 

I suggest you try one of the LabVIEW shipping example to see whether the entire driver is corrupted or just the NI Soft Front Panel.

Please follow the steps below to load the example:
1. In LabVIEW, navigate to 'Help'->'Find Examples'
2. In the 'Browse' tab, navigate to 'Hardware Input and Output'->'Modular Instruments'->'NI-SCOPE'->'Demos'->'niScope EX Getting Started.vi'
3. Double-click to open the VI, and then click 'Run' after selecting your Digitizer on the Front Panel.

Regards,

 

Tarek B
Applications Engineer
National Instruments
0 Kudos
Message 2 of 18
(9,725 Views)

Hi Tarek,

 

Unfortunately I've already uninstalled Labview (I was using Labview 2012) so I can't go through the steps you suggested but I can try running some of the C Ni-Scope example code. I was using the same version of NI-Scope and NI-Visa when Labview was running (I think) and I'm not sure installing Labview was the problem. Actually, come to think of it, I also tried to install Measurement Studio and had a lot of trouble integrating Visual Studio with Measurement Studio, so I was uninstalling and reinstalling NI-VISA and the device drivers during that time - so that's actually probably what messed this up.

 

I'll try the example code and let you know what it gives.

 

Thanks,

Ana

0 Kudos
Message 3 of 18
(9,717 Views)

Ana,

 

Have you seen this KnowledgeBase KB ID 5VIF8S88?

 

NI-SCOPE Soft Front Panel Fails to Load After Installing 2012 Device Drivers DVD

 

-Andrew

National Instruments
0 Kudos
Message 4 of 18
(9,698 Views)

I have - in fact it is the only post I've seen where someone had an issue similar to what I'm experiencing. Unfortunately I tried the fix the post recommends which is making sure nitaglv.dll in the right directory (it is) and doing all critical updates (I had no critical updates relating to this issue)...so far no change.

 

0 Kudos
Message 5 of 18
(9,680 Views)

Sorry Ana - I was in a rush, apparently forgot how to read, and missed that.

 

I have - in fact it is the only post I've seen where someone had an issue similar to what I'm experiencing.

Just to be clear, that is a KnowledgeBase article, which is identifying a troubleshooting issue NI recognized.  That's not a post from another community member.


"I was uninstalling and reinstalling NI-VISA and the device drivers during that time - so that's actually probably what messed this up."
Where did you get the VISA (and other) drivers from?  Was it a download, or a Device Drivers DVD (and which one?)

"Unfortunately I tried the fix the post recommends which is making sure nitaglv.dll in the right directory (it is)"

It links to another KB which has a bat file, which you can run.  Perhaps that nitaglv.dll file has become corrupt, and you want to try to reinstall it?

 

-Andrew

National Instruments
0 Kudos
Message 6 of 18
(9,664 Views)

Ana,

If you can let us know, there are actually a couple of other things we need you to check:

1.  Which directory exactly did you find the "nitaglv.dll" file?

2.  In the install directory for NI-SCOPE, there is a folder called "data", can you verify that it just contains three dll files?

3.  If so, then from the install directory can you double click on the executable "NI-SCOPE Soft Front Panel_Classic.exe", does it run?

4.  Where did you get the installation files? (Disk, downloaded, etc.)

 

In the article that you linked, it mentioned that "NI-Scope SFP runs on the LabVIEW 8.6 Run-Time Engine".  Do you have that installed?  For NI-Scope 4.0+, you will also need the LabVIEW 2010 Run-Time Engine installed as well.  Do you have that installed?

 

Hopefully with your answers we can rule out a corrupt installation, and then we just need to ensure all the dependencies are present.

 

I hope this helps,

Nathan

Product Support Engineer
National Instruments
0 Kudos
Message 7 of 18
(9,656 Views)

Hi everyone,

 

Thanks for all the suggestions - I have nitaglv.dll in C:\Program Files (x86)\National Instruments\Shared\LabVIEW Run-Time\8.6 which may be the wrong directory. I copied and pasted it into the 2012 folder of LabVEIW Run-Time as well (which I fear is one of the things you're just not supposed to do) but it didn't change anything.

 

I was using a downloaded version of the NI Scope 4.00 files to to install NI-Scope. I was a bit mystified when I looked for an NI Scope folder in my Program Files (x86)\National Instruments\ directory and didn't find one, especially as I dimly recall that there once was one there. The Start Menu finds NI-Scope, for what that's worth, under All Programs>National Instruments>NI-Scope and when I go to the Control Panel and click Uninstall Programs, under the National Instruments Software both NI-Scope and NI-Scope runtime appear.

 

I thought that the downloaded installer was the problem so I used the CDs I have of an earlier version (NI-Scope 3.6.2). Nothing changed (ie soft front panel refuses to load, no folder called NI-Scope appears in Program Files (x86)\National Instruments). I have checked multiple times and the installations are supposedly downloading to Program Files (x86)\National Instruments).

 

I did download and run the .bat file from the KnowledgeBase article but nothing changed.

 

I can get the CDs for the newer version of NI-Scope from my admin so I'll try that tomorrow.

 

0 Kudos
Message 8 of 18
(9,646 Views)

Ah sorry, addendum:

 

I found NI Scope in C:\Program Files (x86)\IVI Foundation\IVI\Drivers\niScope

 

the data folder had three dll files: lvanlys, lvinput, and nimaglvu

 

I wasn't able to open NI Scope Soft Front Panel_Classic (it did the same attempt at loading then sudden failing that I've been seeing so far).

 

I do have Labview 2010 Runtime Engine installed (although now that I've got v.3.6.2 of NI Scope from disk I should probably get the right version of the runtime engine).

 

 

0 Kudos
Message 9 of 18
(9,641 Views)

Also tried running the GenericGettingStarted.c example file that comes with the NI-Scope driver - got an error that visa.exe is incompatible with 64 bith Windows, which is an other issue separate from the Soft Front Panel not working, but just wanted to update on that front.

0 Kudos
Message 10 of 18
(9,617 Views)