High-Speed Digitizers

Showing results for 
Search instead for 
Did you mean: 

Auto setup changes impedance setting

Go to solution

Hello, I am using the high speed digitizers to measure the output of a 50 ohm signal.  I wanted to use the niScope_AutoSetup function to quickly get some settings for acquisition.  However, contrary to the VI documentation, which says that Input impedance is "Unchanged by auto setup", it is changing the input impedance on me.  Please see the attached VI and front panel showing the behavior.  I am running Labview 2015 SP1 and NI Scope 16.0.  I'm using a PXIe-5122 digitzer and a PXI-5422 signal generator.


Currently my workaround is to not use niScope auto setup.

Download All
0 Kudos
Message 1 of 7



I've looked through the high speed digitizers help and found specific documentation for this VI.


niScope Auto Setup



Useful Excerpt:

"When the user does not specify an impedance: niScope Auto Setup searches for a signal on both input connectors (first on the 50 ohm input connector, then on the 1 Mohm input connector). If NI-SCOPE detects a signal on the 50 ohm connector (default) then it uses that signal. If NI-SCOPE does not detect a signal on the 50 ohm connector, then it searches the 1 Mohm connector for a signal. If a signal is not detected on any connectors, NI-SCOPE returns a warning and both channels are enabled with 50 ohm impedance."


For whatever reason, it appears that the 50 ohm connector is not sensing a signal. Perhaps we can delay the auto setup call? It may be that the generated signal is not buffered and sent in time for it to be recognized successfully by the 50 ohm connector. Try throwing a wait(ms) function in your sequence structure to test this.


Based on this documentation it also appears that we could also use the auto setup VI in conjunction with a property node to configure the input impedance. Let me know if either of these approaches are successful for you. The property node would be in best coding practice.





Finch Train

0 Kudos
Message 2 of 7

Thanks for giving this a thought for me.  


For the documentation you quoted, you left out an important piece of context appearing before that paragraph, which for the sake of people reading this thread in the future, I would like to include (emphasis mine):


Because NI 5185/5186 devices have two physical connectors (50 ohm input impedance, 1 Mohm input impedance) for each channel, the niScope Auto Setup VI has unique behavior for these devices, as follows:

When the user specifies an input impedance by using a property node to set the input impedance on either channel or both channels: niScope Auto Setup only searches for a signal on that input connector. If no signal is detected, NI-SCOPE returns a warning and both channels are enabled for the input impedance specified.


In my case, for the PXIe-5122, there analog input connectors' input impedance can be configured in software (they're not two separate connectors).  As far as I know, it is not physically possible to detect the output impedance of a source without knowing a priori the input signal level.



I don't really understand what would be the difference of using a property node to configure the input impedance, because I just configured the input impedance using the "niScope Configure Chan Characteristics" VI.   What you are hypothesizing implies that Labview is not honoring the call to niScope Configure Chan Characteristics, which would still be incorrect behavior.


Regardless of whether there is a wait call, it doesn't change the fact that even in the VI documentation you linked, the input impedance setting is still specified as "Unchanged by Auto setup" in the table at the bottom.




0 Kudos
Message 3 of 7
Accepted by gregoryng



Thanks for the update. I did some digging and found why this occurs. Based on the resource below, you will notice it shows that you can only use the 1MOhm input impedance when in AC coupling mode. (Also found on page two of the PXI/PXIe/PCI-5122 specifications)


Why Can't I Set the Input Impedance of the PXI-5122 to 50 Ohms in Soft Front Panel



Using this resource I re-examined the help documentation for the auto setup VI, which you will notice defaults to AC coupling when it is supported by the device.


Vertical coupling AC (when AC is supported; otherwise DC)


AC coupling is set by default thus defaulting to the 1MOhm input impedance setting. I believe the best workaround would be to configure the settings as you have before the auto setup VI in the code you attached. Though the auto setup VI is added for convenience, we have reached a corner case where in this instance it is not a one size fits all solution thus requiring full use of the NI-SCOPE API. Let me know if you have any other questions.




Finch Train



0 Kudos
Message 4 of 7

Okay, I see.  Good catch.  That is kind of annoying, but I can see why AC coupling would be the default.


Assuming that the VI won't be modified to accept an input that allows you to say "don't change the coupling mode," it seems that the VI documentation should be updated to reflect the possibility that the impedance may be changed if the coupling mode gets changed. Though I suppose perhaps it is technically correct that it is "unchanged by the VI" if a lower driver layer changes the impedance.


0 Kudos
Message 5 of 7



Thanks for the follow up. This is an interesting case because with certain devices you would not experience this issue depending on what the device capabilities are (some have 50 Ohm impedance in AC coupling mode). For the sake of future engineers encountering this issue, would you mind marking my previous response as a solution if you were satisfied with the answer?




Finch Train

0 Kudos
Message 6 of 7

Always wonder why an auto setup is needed?


OK, thanks to the auto setup button of modern DSOs I recently got a nice analog Tektronix 464 storage scope. Most probably because the former owner didn't know how to handle the trigger! 🙂 🙂
Greetings from Germany

LV since v3.1

“ground” is a convenient fantasy

'˙˙˙˙uıɐƃɐ lɐıp puɐ °06 ǝuoɥd ɹnoʎ uɹnʇ ǝsɐǝld 'ʎɹɐuıƃɐɯı sı pǝlɐıp ǝʌɐɥ noʎ ɹǝqɯnu ǝɥʇ'

0 Kudos
Message 7 of 7