Hardware Developers Community - NI sbRIO & SOM

Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Highlighted

SOM sudden shutdown followed by boot up

Hi,

 

Been experiencing intermittent issues with the SOM suddenly shutting down (no warning and sudden connection loss)  when I initiate 45 DO on our PCB pins to a state. I don't see the SOM losing power or having the voltage drop. Does anyone have any suggestions of any errors or pins what could be causing this and I could monitor?

 

The issue does become more frequent when the board temperature rises to 50 degrees, however, the SOM FPGA only reaches a maximum of 70 degrees C, nowhere near the 98-degree thermal shutdown.

 

On the PCB the 45 pins use LVDS signaling going to some chips that are powered with 5V coming from their own linear voltage regulators. They do not use the 3.3V rail powering the SOM.

0 Kudos
Message 1 of 2
(397 Views)
1 REPLY

Re: SOM sudden shutdown followed by boot up

How are you monitoring power? Are you pretty confident that there isn't a momentary brown out or black out? If you're sure that the SOM isn't losing power, it might be useful to monitor the CARRIER_RST# signal. This would tell you if the SOM is entering a reset state.

 

Is the behavior dependent on the number of DO initiated at the same time? Does reducing it from 45 change the frequency of the issue?

 

It would also be interesting to try something similar on the carrier reference board. That way you can narrow down whether the problem is carrier-dependent.

 

0 Kudos
Message 2 of 2
(368 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.