Hardware Developers Community - NI sbRIO & SOM

Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Highlighted

9561 SOM Status LED flashing...no communication

Today I booted my 9651 SOM and the status LED is flashing and I have no communication with it.

Attempted:

1. RESET button on 9651 several times. - Status still flashing.

2. Power cycle the 9651 several time - no joy.

3. Did a long RESET...held RESET for 10 seconds, until Status turns back ON - no joy.

I have an I2S connection and a TTL pulse are the only external electrical signals which have been working fine in development for the past weeks.

I cannot find the Status Flash codes in the 9651 manual...so I am posting the question here.

Regards

Jack Hamilton

0 Kudos
Message 1 of 11
(4,951 Views)
10 REPLIES

Re: 9561 SOM Status LED flashing...no communication

Hi Jack,

I'm sorry to hear you're having trouble with the SOM. For this community group, we are trying to focus more on the hardware design aspects/issues, and I think your post might be better suited in the Real-Time Measurement and Control software group.

One thing you'll want to clarify is whether you are using the reference carrier board or your own custom board currently and when this issue appeared.

Eric

*Note that you can find LED Status information in table 7 on page 12 of the manual. The software community group can help step you through trouble shooting issues here as well.

0 Kudos
Message 2 of 11
(3,885 Views)

Re: 9561 SOM Status LED flashing...no communication

Good Afternoon Jack.


Sorry to hear that the SOM is not behaving as expected.


Can you try the recovery.cfg file I've uploaded to ftp.ni.com/outgoing. Its labeled sbRIO-9651.zip (no password). This will reset the device to factory specification and should put the controller back into a safemode so you can reimage it from there with software.

To reset the repair the safemode on your controller you will need a FAT16 or FAT32 USB drive with FAT on the first partition. Follow the steps below in order to repair the safemode on your controller.

  1. Copy the recovery.cfg to the thumb drive.
  2. With device powered off, plug in the USB drive to the controller.
  3. Hold down the reset button while powering on the controller. Continue holding the rest butting until the status light turns on, then release the reset button.
  4. Wait for the controller to boot. This should take less than a minute.
Kyle Hartley
Software Engineer
NovaCentrix
0 Kudos
Message 3 of 11
(3,885 Views)

Re: 9561 SOM Status LED flashing...no communication

I wanted to post there was nothing wrong with the SOM, the wrong power supply (under voltage) was mixed with the SOM PS. Murphy had to put the same connector on the wall warts?!.

The SOM is now up and running normally and reliably.

Regards

Jack Hamilton

0 Kudos
Message 4 of 11
(3,885 Views)

Re: 9561 SOM Status LED flashing...no communication

Hi Jack,

That is great to hear!

- Tanner

Tannerite
National Instruments
0 Kudos
Message 5 of 11
(3,885 Views)

Re: 9561 SOM Status LED flashing...no communication

Hi Kyle,

 

I have same issue, but I couldn't find the sbRIO-9651.zip in the ftp. Would you please provide it again?

 

Best regards

Hamid Naghizadeh

0 Kudos
Message 6 of 11
(2,726 Views)

Re: 9561 SOM Status LED flashing...no communication

Hamid,

 

Is the Status LED continuously flashing, or is it flashing in a pattern? You can find what the different patterns mean on page 13 of the manual.

 

If you're still able to view the device in MAX, the best option before trying a full safe-mode recovery is to do a format from MAX.

0 Kudos
Message 7 of 11
(2,721 Views)

Re: 9561 SOM Status LED flashing...no communication

The Status LED is continuously flashing, It doesn't show  up in the NI-MAX, so I can not format it.

 

Thanks

0 Kudos
Message 8 of 11
(2,704 Views)

Re: 9561 SOM Status LED flashing...no communication

The recovery file is uploaded to ftp.ni.com/outgoing in sbrio-9651.zip, as before. If you're unable to recover by following Kyle's steps on the first try, I recommend trying a different USB drive. I've seen cases where some drives don't work.

0 Kudos
Message 9 of 11
(2,695 Views)

Re: 9561 SOM Status LED flashing...no communication

Hello,

  

   I have the same problem and I need to recover the SOM. Is is possible to upload this file again?

 

  Thanks,

 

       Jaume

0 Kudos
Message 10 of 11
(130 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.