Git User Group

cancel
Showing results for 
Search instead for 
Did you mean: 

Corrupt globals.vi using git

<This is a duplicate of this question, but I someone requested that I also post here: http://forums.ni.com/t5/LabVIEW/Corrupt-globals-vi-using-git/m-p/3087628#M882698>

I should also note that I am not using any git plug-ins for LabVIEW -- just plain old git (which may not be the smartest thing in the world...)

--------------

Hello,

I am developing a LabVIEW program using v2013 and I keep it under version control with git.

Recently, I tried to push a few changes to the repository from a computer with LabVIEW 2014. I added a new vi and changed the globals file.

Unfortunately, there is something corrupt about the globals file. Here is the behavior I observe:

- When I copy and paste a reference to a global in a vi that uses it, I cannot wire it to anything or change the global variable name (the gray selection menu does not appear). Double clicking does not take me to the globals.vi file.

- Any globals that were already in a vi behave as before: they are wired and you can select which global variable from the menu. Double clicking will open globals.vi file.

- When I try to create another global in the globals vi file using copy + paste, it is not editable (either the value or the name)

Here's what I've tried, with no change in behavior:

- reverting my changes to a previous commit (before I merged with the newer version of labview)

- recloning repository

- copying a version of globals.vi that was saved for v2013 (on the v2014 computer) and replacing the globals.vi file on the v2013 computer.

What should I try? I'd love to not have to rebuild the globals file from nearly scratch. Are there particular temporary files that need to be removed for globals to start to work again?

Thanks,
Kristen

0 Kudos
Message 1 of 1
(3,800 Views)