Forum Italiano sui Prodotti NI

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Problema labview switch e arduino

Vorrei sapere se è possibile con labview interdire uno switch quando un altro è acceso???
Cioè per esempio voglio che lo switch 1 sia funzionante e che lo switch 4 sia bloccato .
E' possibile???? da considerare che gestisco perfettamente degli switch con labview e arduino con firmware LINX.
Grazie

0 Kudos
Message 1 of 12
(575 Views)

Magari lo conosci gia', un modo potrebbe essere creare per lo switch un "property node" per la proprieta' "disabled" (selezionare switch -> tasto destro -> create -> Property Node -> Disabled). Quando lo si crea e' in lettura poi eventualmente puoi cambiarlo in scrittura (selezionare switch -> tasto destro -> change All to Write) e cosi' puoi cambiare lo "stato" dello switch. Poi devi inserire questi "property node" nel tuo VI per disabiltare/abilitare lo switch quando vuoi.

0 Kudos
Message 2 of 12
(543 Views)

Mi puoi dare per favore una mano.....sto impazzendo...ho postato lo schema....se per favore potresti gentilmente farmi un esempio

0 Kudos
Message 3 of 12
(537 Views)

Allego un piccolo esempio

0 Kudos
Message 4 of 12
(519 Views)

Ti ringrzio sto provando.....

Non riesco ad impostare enabled e disabled and grayed out sull'operatore select....Come faccio????

0 Kudos
Message 5 of 12
(513 Views)

Vai sull'ingresso del "propertyNode:disabled" -> tasto destro -> create -> constant

0 Kudos
Message 6 of 12
(511 Views)

Si scusami già fatto...però adesso ho un problema non riesco a collegare il select al property node disabled e come faccioa mettere la scritta s1 abilita / disabilita s2??? Ho già messo sul property node CHANGE ALL TO WRITE.

Ti ringrazio molto dell aiuto

0 Kudos
Message 7 of 12
(505 Views)

La scritta "s1 abilita / disabilita S2" e' un semplice commento che puoi mettere o meno. Per mettere un comment doppio-click in un punto libero del VI e ti si apre la finestrella in cui puoi scrivere.

0 Kudos
Message 8 of 12
(496 Views)

si questo fatto pure....il problema è che non riesco a collegare il SELECT al property node DISABLED...Da considerare che già ho impostato CHANGE ALL TO WRITE.

0 Kudos
Message 9 of 12
(489 Views)

Prova prima a collegare ai 2 ingressi del "select" i suoi ingressi, cioe' le costanti con Disabled,etc... Poi prova a collegare l'uscita del "select" all'ingresso blu del Property node.

0 Kudos
Message 10 of 12
(478 Views)