Forum Italiano sui Prodotti NI

annulla
Visualizzazione dei risultati per 
Cerca invece 
Intendevi dire: 
Rispondere

Problema Property node DISABLE

Problema Property node DISABLE

Buongiorno a tutti.....mi potete per favore aiutare non so come risolvere.Allego foto.

Praticamente ho bisogno di disabilitare alcuni switch (boolean) durante il funzionamento di altri.Il problema è che quando creo property node riguardanti lo stesso switch si va in conflitto.....Come posso risolvere.....C'è un'altra soluzione????

0 Kudos
Messaggio 1 di 3
242Visualizzazioni

Rif.: Problema Property node DISABLE

Cosa intendi con "si va in conflitto"?

Hai provato a sequenzializzare il codice usando il terminale d'errore dei property nodes?

In ultima analisi potresti pensare ad una FGV che renderebbe il tutto più leggibile e meno sensibile ad accessi multipli alla stessa risorsa.

0 Kudos
Messaggio 2 di 3
203Visualizzazioni

Rif.: Problema Property node DISABLE

Ciao EdNed, e benvenuto nel forum.

Questo thread è una riproposizione del precedente, nel quale mi pareva di aver dato un'indicazione sulla natura del problema. Che evidentemente non è stata capita.

Chiaramente, se lo switch PV è true e HV è false, RGN viene continuamente abilitato e disabilitato (fenomeno descritto da Louis83 come "vibrare" o "tremare"); questo, credo, è quello che Louis83 intende con "conflitto". Se così è, non è certo un problema di programmazione, ma di chiarirsi la logica del programma: quella proposta non sta in piedi.

E' necessario usare un solo property node per l'abilitazione di RGN (e simili); ogni altra elaborazione, per decidere se abilitare o meno, va fatta a monte.

 

Paolo
-------------------
LV 7.1, 2011, 2017
0 Kudos
Messaggio 3 di 3
191Visualizzazioni