Forum Italiano sui Prodotti NI

annulla
Visualizzazione dei risultati per 
Cerca invece 
Intendevi dire: 
Rispondere

Linux Vi package manager

Linux Vi package manager

Buongiorno a tutti, mi chiamo Francesco 

Vi scrivo perchè sto riscontrando un problema nell'installazione del manager di librerie di labview su linux. Vorrei installare il package manager di labview, il problema è che non riesco a installarlo. 

Seguendo le istruzioni, per prima cosa ho scaricato il tar dal sito https://vipm.jki.net/download

 
vipm.jki.net
© 2018 JKI All rights reserved.JKI All rights reserved.

 

Una volta scaricato lo estraggo e, come dice nel file txt con le istruzioni, sposto la cartella JKI in /usr/local col comando sudo mv JKI /usr/local

Fin qui tutto bene. 

Il passo successivo è andare nella cartella LabVIEW2015SP1RTE_Linux e installare tutti i pacchetti rpm. Usando rpm però mi dice che non posso installarli e, cercando in rete, ho trovato un modo alternativo, cioè usare alien. 

Allora faccio questo script 

 

 

#!/bin/bash
 
for file in `ls ./*.rpm` ; do
      sudo alien -i --scripts ${file}
done
 
in modo da installare tutti i file, ed effettivamente li installa. Automaticamente mi installa solo i pacchetti compatibili col 64 bit, scartando quelli a 32.
L' ultimo passo è quindi avviare il software col comando sudo /usr/local/JKI/VIPM/vipm 
Qui mi da questo errore:
 
Can't find library liblvrt.so.15.0
Make sure this library is installed in your LD_LIBRARY_PATH
search path, or in /usr/lib
 
Quel file che dice di scaricare nell'ultima riga è in pratica la cartella LabVIEW2015SP1RTE_Linux dell'archivio .tar detto prima.
Non so da che parte farmi per risolvere questo errore perchè il file liblvrt.so.15.0 da me è presente nella cartella /usr/local/lib64 
Ho provato a creare anche questa variabile LD_LIBRARY_PATH con il comando export LD_LIBRARY_PATH=/usr/local
Ma continua a darmi questo errore. 
 
Cosa può essere?
 
Oppure c'è un modo su linux per installare linx senza passare da VIPM? Dovrei installare linx.
Sono alle prime armi con labview, è un corso universitario iniziato da poco.
 
 
Vi ringrazio in anticipo!
0 Kudos
Messaggio 1 di 3
328Visualizzazioni

Rif.: Linux Vi package manager

Salve Francesco,

le propongo qualche suggerimento in merito alla sua richiesta.

  • Manca il runtime engine a 32 bit. Il VI Package Manager richiede la versione a 32 bit del runtime di LabVIEW, mentre lei ha installato quella a 64 bit. Posso consigliarle alcuni documenti su come installare pacchetti RPM a 32 bit su distribuzioni Ubuntu a 64 bit.
  • In alternativa può provare ad installare una versione più recente del VI Package Manager. A tal proposito può fare riferimento a questa discussione sul forum. A proposito, quale versione di LabVIEW utilizza?
  • Comunque la informo che Ubuntu non è tra le distribuzioni Linux ufficialmente supportate dai software NI, in quanto i pacchetti usati per distribuire il software sono di tipo .RPM e non .DEB, cioè il formato nativamente supportato proprio da Ubuntu.

Cordiali saluti

Alessia

0 Kudos
Messaggio 2 di 3
107Visualizzazioni

Rif.: Linux Vi package manager

Ho provato a installare anche la versione del runtime a 32 bit reinstallando labview da zero 

Mi da lo stesso errore 

A sto punto credo che sia un problema di compatibilità con Ubuntu, proverò su un'altra distro di Linux

Grazie per le informazioni! 

0 Kudos
Messaggio 3 di 3
96Visualizzazioni