FlexLogger

cancel
Showing results for 
Search instead for 
Did you mean: 

RMS calculated channel

Highlighted

Hello,

I have an issue with the RMS value function of Flexlogger. I use Flexlogger 2020 R4 and NI 9244 module with Cdaq9189.

In my project, I use many calculated channels X>Y (40 calculated channels), I don't know if it is the problem.

lfc21_0-1603701546940.png

lfc21_1-1603701575296.png

The block size is approximatively 1s for the rms function. Sampling 1Hz.

At the creation of rms calculated channels, it works, but, when I restart my project, the block size changed to 0 and errors appears:

lfc21_2-1603701727540.png

lfc21_3-1603701739861.png

 

If I create only a project with rms channels, it works, even when I restart the project.

 

I don't understand why I have an issue.

 

Any idea? 

Thank you

 

 

 

0 Kudos
Message 1 of 9
(318 Views)
Highlighted

I have tried to reproduce the problem, but it worked fine for me. If you browse to your project's folder and edit the "Channel Specification.flxio" in notepad and search for BlocksizeInSeconds, does it have 0, or a value of 1? Please send me your project if everything looks good in this file, but the FlexLogger application is initializing all those RMS channels with a Block Size of 0. If the value is 0 in the file, we would be interested to know how you got into this state. Can you edit the file, set them back to 1 and see if you can reproduce the problem?

 

Thanks,

Brad

0 Kudos
Message 2 of 9
(256 Views)
Highlighted

@ifc21, I have a few other questions to add to Brad's response:

  • If the block sizes are set back to 1 (ish) do the channels work again?
  • What happens if you disable the channels before save/ close/ load? (hoping this can unblock you from using your project now as we troubleshoot with you).
  • What sample rates are you using?
Briana C.
FlexLogger
SW Engineering Manager | NI R&D
ni.com/support
0 Kudos
Message 3 of 9
(218 Views)
Highlighted

Hello, 

Sorry for the delay...

The BlocksizeInSeconds is set to 1 in the  "Channel Specification.flxio"  file.

If the BlocksizeInSeconds is set to 1s, at the opening of the project, the parameter is changed to 0, and I have an error.

If the BlocksizeInSeconds is set to 2s, at the opening of the project, the parameter is changed to 1, and it works.

 

See my project in attachment.

 

If you understand what's going on... 🙂

0 Kudos
Message 4 of 9
(176 Views)
Highlighted

Hello BriBear,

  • If the block sizes are set back to 1 (ish) do the channels work again? Yes
  • What happens if you disable the channels before save/ close/ load? (hoping this can unblock you from using your project now as we troubleshoot with you). Where can I find disable option? I can remove the RMS function, in this case, no problem.
  • What sample rates are you using? 1Hz on all channels
0 Kudos
Message 5 of 9
(169 Views)
Highlighted

Hi lfc21, 

 

Thanks for the reply.

 

You can disable a channel (or multiple selected channels) using the disable icon on the right-hand edge of a channel:

BriBear_0-1604942215422.png

 

Briana C.
FlexLogger
SW Engineering Manager | NI R&D
ni.com/support
0 Kudos
Message 6 of 9
(163 Views)
Highlighted

Thanks for sending the FlexLogger project. We were able to reproduce the issue with your project and are investigating now. One of our FlexLogger developers will let you know what we find out.

 

Thanks,

Brad

0 Kudos
Message 7 of 9
(150 Views)
Highlighted

Hello,

 

Thanks for reporting this issue. The root cause is due to a circular reference and rounding down, that results in the block size to be rounded down to 0 when the project is reopened.

As a workaround, try setting the block size to a value higher than 1s, and verify in the configuration dialog that it is coerced to a value that is either 1s or slightly higher (but not lower like 0.925). That value is recomputed based on the sample rate of the module.

This bug will be fixed in the release of FlexLogger which will be available for download shortly. I will update the thread again when it is available.

 

Hope this helps.

 

Best regards,

 

Christophe

0 Kudos
Message 8 of 9
(44 Views)
Highlighted

Hello,

Thank you for your reply. For the moment, I set the bloc size to 2 and I have no other problems.

First issue I have found on Flexlogger 🙂

Best regards

 

0 Kudos
Message 9 of 9
(9 Views)