FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

tdms runtime 8.2 error 1

<meta http-equiv="Content-Type" content="text/html; charset=utf-8"><meta name="ProgId" content="Word.Document"><meta name="Generator" content="Microsoft Word 11"><meta name="Originator" content="Microsoft Word 11">


I have two arrays with xy-plot data that I want so save to a tdms file and also write some further information about the plot. When I couldn't get this to work in a built executable I scaled down the problem and found that there was problem with LabView tdms and runtime engine. I can't write channel names when I’m saving channel data, it doesn't matter if I’m writing a group name or not.

I've attached two printscreens of my application; the top one doesn’t create any tdms-file after being compiled but works fine when I run it in LabView. The bottom application creates a file when I’m running it but results in a pop-up LabView error that shows a memory error (memory.cpp, line 342, LabView 8.2.1).

Code compiled in LabView
Runtime engine 8.2

Is there any better solution for what I want to do? Or any solution of the runtime problem?

0 Kudos
Message 1 of 5
I am having the same or a similar problem.  I built an application that creates a TDMS file to hold the data.  It runs fine under LabVIEW 8.2.  The TDMS file is created and saves the data, no problems.  However, when I build the application and run the executable I get an error "Error 1 occurred in TDMS Write"  andthe file isn't created.
0 Kudos
Message 2 of 5
0 Kudos
Message 3 of 5
You recommended in that thread, "Actually, that rings a bell now. As far as I can recall, you'll also be fine if you pass an array of channel names (with just one element) into TDMS Write."  My vi aready is doing that, passing the channel names and data as 1 dimensional arrays.  In the case of the channel it is a 1 dimensional, 1 element array.  I still have the problem that the vi runs under LabVIEW 8.2 but gets this error 1 when compiled and run as an executable.
0 Kudos
Message 4 of 5

I would recommend you to upgrade to 8.2.1 since that solved all my problems

0 Kudos
Message 5 of 5