FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

repaired cfp-421 relay boards not working in a cfp-2000 System - power light off

Hi, we are using a cfp-2000 as a control system for various biology related experiments and prototypes. The first configuration was controlling valves & pumps. I recently took that configuration apart after it had been sitting unused for a while and started to re-configure for a different application to control lights. I had trouble right off the bat, couldn't talk to the cfp-2000 controller. I sent it in for repair\replace and then went through a little work to re-setup in MAX. I got the IP connection working and I can turn on\off the leds on the cfp-2000. Then I found that the three cfp-421 relay boards were not working. So I sent them in for repair. They came back but when I add them to the Remote System in MAX, I can't communicate with them. There is a message indicating that they are not connected (I don't have the exact wording but can get it if that will help). The Ready indicator is on at the cfp-421 modules but the Power indicator is off. I tried all three returned modules individually with no luck. Any help is appreciated. We have spent quite a lot of money on repairs and have fallen behind on the project. Thank you. Kevin
Message 1 of 5

What version of MAX and what version of the fieldpoint driver are you using?  Check to see if they are up to date.


Take a look at this thread for advice where the person also had problems getting a cFP-RLY-421 board recognized.

0 Kudos
Message 2 of 5

Thanks for responding.


MAX version

Fieldpoint drivers 5.02


The messages are "The module or item addressed does not exist" and "The device is offline. Make sure the device is connected and its power is on".


If I reset the cfp-2000, all relays activate on the cfp-421 (the eight indicator lamps light) for a few seconds and then go off.


I wonder if something is broken in the backplane because the cfp-421 power light is off. 


0 Kudos
Message 3 of 5

Have you powered down the entire system, removed the modules, and reinsert them to make sure they are seated to the backplane correctly? Any chance of bent pins (unsure of what type connectors are used).



"It’s the questions that drive us.”
0 Kudos
Message 4 of 5

Yes, we have four cdp-rly-421 modules. I checked the pins and tried them all in different slots.


I just downloaded nifpsw606f1.exe to update the drivers.

0 Kudos
Message 5 of 5