FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

output of FieldPoint 401 module does not go low

We are useing the 401 module to control a bank of Phoenix contactor relays (can get the exat P/N if needed).  we are seeing signifigant field failures on the 401 modules in that the output no longer goes low.  It goes from 24Vdc to ~20Vdc and allows for enough current to keep the relay on.  We have sent several of these modules back to NI and they say they send them back as no problem found.  We are useign the 24Vdc common connection and no external flyback circuit, except for a flyback diode that is installed in the phoenix contactor relay receptical.
 
My first thought is leakage current,  but 7 mA leakage current is a lot. So Flyback, but this seems odd as these are very small relays.  We do have very large inductive and capacitive loads in our system, but they are Isolated from the 401.
 
Thank you for your help!
0 Kudos
Message 1 of 21
(8,491 Views)
Any relay driven by a digital I/O should have a some sort of snubber/flyback diode installed across it's coil.  It sounds like you are latching up the digital output.
 
You said you did not have a flyback circuit but you did have a flyback diode installed in the relay receptical.  Is that diode across the coil of the relay?  What Phoenix P/N are you using?
Message 2 of 21
(8,489 Views)

We are useing the Phoenix contact Socket PLC-BSC-24DC/21 (http://www.alliedelec.com/Images/Products/Datasheets/BM/PHOENIX_CONTACT/Phoenix-Contact_Interconnect...) which has a "Dampening Diode" built in to the base.  We use the Phoenix Contact No.2961105 relay. 

Additionally the LED turns on and off as expected.

0 Kudos
Message 3 of 21
(8,486 Views)

Phoenix Contact info is a bit fuzzy as to just what is across the coil of the relay.  You might want to install your own flyback diodes.  I don't think this is an issue with leakage currents.  I really think the some sort of electrical noise is latching up your outputs.  Best guess is that noise is either coming in via the output wiring or through your 24VDC supply.  A scope might help you find the culprit.

Standard practice for me is to install a flyback diode across a DC coil or a RC snubber across an AC coil of any relay/contactor in a tester/system.  The trick is to get the diode/snubber as close to the coil as possible.

0 Kudos
Message 4 of 21
(8,483 Views)
we can try it.  Do you use discrete components or is there something available that has these parts built in.  The only reason I ask is we have 3 of these modules per unit and about 15 units in the field. So the time savings would be huge.
0 Kudos
Message 5 of 21
(8,481 Views)

The RC snubbers I use are from Electrocube.  Here is link to doc  http://www.electrocube.com/pdf/cap13.pdf.  You will probably need to experiment to find which RC combination does the best job.

Most of the time I use a simple 1N4007 flyback diode on DC coils.  This could be installed directly at the terminal block.

At some point you will still need poke around with a scope.  I'm guessing it will take a pretty big disturbance to cause this. 

0 Kudos
Message 6 of 21
(8,477 Views)

Hi Gene,

Thank you for contacting National Instruments.  From what you are describing here, I think there is another aspect that is worth investigating when experiencing these symptoms. 

FieldPoint modules can be damaged over time by noisy power supplies.  When damaged the [c]FP-DO-401 will have channels that are stuck in the ON position. The LED will turn on and off correctly, but will always output a high voltage. To prevent against this type of failure you will need to attach a properly selected transient voltage surge suppressor between V and C.  It is recommend to use a transient voltage surge suppressor (TVSS) to prevent this despite the power supply that is used. However, once the module is damaged, it will need to be repaired by our repair department. Also, it is also wise to use a TVSS with new modules. If a module has previously been exposed to transient voltages, attaching a TVSS will only prevent further the damage from occurring.

If you are using a 24V supply, then one of the following TVSSs could apply:

Littlefuse - LCE24A

http://www.mouser.com/search/Refine.aspx?Ne=1447464+254016&Ntt=*576LCE24A*&Msb=0&Mkw=576-LCE24A&N=1323038

ST Micro - P6KE27A

http://www.mouser.com/search/Refine.aspx?Ne=1447464+254016&Ntt=*511P6KE27A*&Msb=0&Mkw=511-P6KE27A&N=1323038

Vishay - P6KE27A

http://www.mouser.com/search/Refine.aspx?Ne=1447464+254016&Ntt=*625P6KE27A*&Msb=0&Mkw=625-P6KE27A&N=1323038

To hook this up to the DO-401, connect the side of the transient voltage suppressor with the line/bar to the V terminal on the terminal block, and then other end to the C terminal on the terminal block.

To return your product for repair, a service request can be made here.  You will need to provide software and hardware information, and request repair in the ‘Question Type’.

I hope this helps!  Let me know if you have other questions or need additional clarification.  Have a great day!

Jason W.

 

National Instruments
Applications Engineer
Message 7 of 21
(8,429 Views)

Jason,

Can you elaborate a bit more on what you mean by "noisy power supplies"?  Are you refering to an inferior power supply that generates its own electrical noise/transients or to electrical noise/transients from the AC input to the supply that make it through the power supply and to the cFP?

0 Kudos
Message 8 of 21
(8,419 Views)

Centerbolt,

What I am referring to here is the second conditions you described, the electrical noise/transients from the AC input to the supply that make it through the power supply and to the cFP.  Sometimes power supplies will spike when they are plugged in, and this may cause a noise problem.

Jason W.

National Instruments
Applications Engineer
0 Kudos
Message 9 of 21
(8,403 Views)
Jason,
 
I'll agree that a transient on the supply to the module would cause such a problem and the installing the TVSS will help protect the module. 
 
 
Gene,
 
Jason's reply verifies that electical transients on the module supply can cause latchup/damage.  I also think that transients on the module outputs could cause the same problem.  If your system gets powered up and down a lot then Jason may have the answer.  If your system is on all the time and latching up, then I think you need to concentrate on coils of relays and contactors.  Have you had a chance to look at signals with scope?
Message 10 of 21
(8,393 Views)