FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

monitorizacion transmisor 4-20mA presion con cfp-ai-111

Hola,

 

estoy probando con un transmisor de presion piezorresistivo con lazo de salida de 4-20mA (http://www.nuovafima.com/Corporate/jsp/index.jsp?p_gadgetURL=pagemapping.jsp%3Fid%3Dcatalogo&p_conte...

 

para ello uso el modulo cfp-ai-111 y conecto en el mismo el transductor usando una fuente externa en los terminales V y C del módulo según indica el manual del cfp (http://www.ni.com/pdf/manuals/373281b.pdf) y usando como modelo con ligeras variaciones el ejemplo http://zone.ni.com/devzone/cda/epd/p/id/2819

 

Todo va bien, consigo conectarlo, ejecutar el vi correctamente y medir la mínima corriente sin ningún problema (4mA--0bares).

 

Le he conectado a la salida una "Waveform Chart", para monitorizar gráficamente la medida, aquí surge mi duda, la forma de la grafica pensaba que sería una curva lineal en función de los datos. En vez de esto me sale una especie de picos correspondiente a la medida real, adjunto la imagen.

 

¿Tiene que salir así? ¿El módulo o el transmisor envían pulsos? o es problema de la programación del chart

 

 

0 Kudos
Message 1 of 2
(4,982 Views)

 Bien, he hecho una prueba con un VI de lectura básica usando esta vez sólo un canal con el "fieldpoint io point", en este caso sí se genera una gráfica lineal. Luego se me ha encendido la bombillita (en mi cabeza) y he usado el anterior VI pero seleccionando el canal 0, y todo ok.

 

 Definitivamente, algo pasa con el "chart" cuando monitorizo todos los canales seleccionando el canal "All". Entonces, si me interesa que salgan todos los "plots" aunque no haya sensores en el resto de canales (pensando en añadirlos sobre la marcha sin tener que modificar el control), ¿cómo pensais que debería configurarlo?

 

saludos.

0 Kudos
Message 2 of 2
(4,973 Views)