FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

issues with cfp AIO 600 output



I am trying to get cfp AIO 600 to output current, for this I am using the sample VI for the cfp AIO 600. I cannot get current on the output and I have trouble troubleshooting the issue.


1) How should I connect the wires to the AIO 600, the manual shows two COMs for out 0, which one should I use ? 





This is how the wires are at the momment connected (9 and 26): 





I am using the sample vi (FieldPoint\Getting Started\ Analog Input and", after followed the instructions, it runs without any error. 


Also the indicators in the FP 600 are all red all the time: 




I am connecting the wires from 9 to a resistance (750 ohms) then a multimeter and back to 26. I don't see any current though. 
How should I troubleshoot this ? 



0 Kudos
Message 1 of 7

First, it is possible that your AIO-600 is damaged.  I don't know how you prove that it is.


What is the voltage you are supplying to the unit?


I would try connecting to pin 10 instead of 26.  I think it shouldn't matter at all, that all the commons are tied together.  But since 10 more naturally pairs with 9, I'd use that.


If you measure the voltage across pin 9 and 10, and/or pin 9 and 26, what voltage do you get?  If you completely open the loop, what voltage do you get?  What about the voltages out of pins 11, 13, and 15 with respect to their corresponding commons?


What current level are you commanding the AIO-600 to output at the moment?


You have a heavier black wire coming out of pin 18 (a common).  Where is that going to?

0 Kudos
Message 2 of 7


Thanks for the quick answer. So I tried between 9 and 10 and I still don't read any current (nor voltage). Voltage between 25 (Vsup) and COM was 15.6V.

I tried with a resistance of 320 ohms between 9 and 10 (and the VI running with the output set to the maximum 20 milli amp) still nothing.




I will try the other outputs (11 13 and 15) tomorrow when I go back to the tab.

I just want to make sure I understand how I sould be connecting everything.

V and C should be connected to power source of maximum 30 vdc and 2 amps. And 9 and 10 should be connected to a load (resistance/relay) right ?

as for pin 18 (I think I should remove it) it is connected to C but I read in the manual that they are internally connected so i sould remove it.



0 Kudos
Message 3 of 7

[edit] same message got posted twice.

0 Kudos
Message 4 of 7

And what is the voltage across 9 and 10.  (Iout and Common)?  With and without the wires connected in the loop?   Was the 15.6 V you say were across Vsup and common actually Iout and common?


What is the voltage between V and C at the supply terminals?


15.6V divided by 750 ohms gives a current of 20.8 mA  Pretty close to 20 mA..  (20 mA at 15.6V would be a 780 ohms resistance.)


When you had the 320 ohms you say you got "nothing", but did you really?  Could it have been something like 6.4 V?



Is the ready light lit on your AIO-600 module?  I can't tell from the pictures.


What version of LabVIEW and fieldpoint drivers are you using?


I've used the cFP-AIO-600, but it was years ago.  If I recall, I think it was a bit newer module than others when it came out, and I needed to install a newer version of fieldpoint drivers than I had at the time for it to work.  I don't remember how I knew I had problems to begin with.  If I had to guess, it wasn't showing up in MAX.

0 Kudos
Message 5 of 7


I just removed all the wires and put them back and not it works. The way they are connected is : 

Power supply (16V) to 2amp Fuse to V and C. The load between 9 and 10. 


Thanks for the replies, 

0 Kudos
Message 6 of 7

Hi Amineben,


In your first post you mentioned the module status LEDs are red. According to our manual this could indicate several problems:


"Each channel has a monitoring circuit that compares the actual output current to the specified output current. If the [c]FP-AIO-600 cannot source the specified output current for one or more channels, the monitoring circuits turn on a red STATUS LED for each affected channel and report the error condition to the network module."


"For more information, refer to the Specifications section. VSUP I OUT COM C V To Next Channel + – 10–30 VDC External Power Supply 2 A Max [c]FP-AIO-600 Load Current Source Circuit 12-Bit DAC FP-AIO-600 and cFP-AIO-600 10 If the output of a [c]FP-AIO-600 channel is set to 0 mA, the monitoring circuit does not register an error condition because the [c]FP-AIO-600 can always source zero current, even to an open loop. Leave any unused and unwired channels in the default state to avoid error conditions."


The primary reasons for this are:


1. The error condition is caused by an open current loop—either the load device or the external power supply is disconnected.


2.The monitoring circuit also detects errors caused by load impedances that are too high and by external power supply voltages that are too low.


Can you try a different power supply and can you try swapping out the wires?




Kyle S.
Applications Engineer
National Instruments




0 Kudos
Message 7 of 7