FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

internal fuse cFP-RLY-425

is there an internal re-setable fuse in the cFP-RLY-425 module?  i have an application that is controlling power relays by using the relay module to switch the 120VAC.  i have found that after some use the relay module would stop working but by resetting the controller it would come back online.  i think one of the loads that i am switching is causing a spike that shuts down the module but the power and status LED are always on.
0 Kudos
Message 1 of 8
It sounds like something is latching up from electrical noise.  Do you have other modules installed and do they continue to operate after the cFP-RLY-425 module quits working?
What kinds of loads are you switching with the relay outputs?  AC or DC?  If you are switching an inductive load without a snubber,  it will generate a very large noise spike.
Message 2 of 8

I had several cFP-RLY-425s that stopped working.  I was using them to switch small 120V AC Coil relays (180ma inrush, 33ma hold).  In Max, it looked like they were loosing communications with the processor (the power & status lights were still on, even though it wasn't communicating).  

I installed RC snubbers on every AC realy in the panel, but was unable to find the cause.  I changed both the backplane and the processor.  I also isolated the 24V supply that runs the processor. 

After additional testing (using MAX) I found that, sometimes, when the processor would come out of a reset or reboot, it just wasn't communicating with the relay card...even before I closed any relays anywhere in the I figured it had nothing to do with my design or install.

I had to get the project up & running, so I redesigned it to use cFP-DO-401s and DC relays, and sent the cFP-RLY-425s back to NI for them to figure out the problem.

Good luck,



0 Kudos
Message 3 of 8

It could be something as simple as the module wasn't completely/perfectly seated. We ran into this problem with two different FP-RLY-420 modules. About once a month, all the relays on a particular module would switch ON for no reason. A firm push to fully seat the module solved the problem.



Message 4 of 8
I have the same problem with a cFP-RLY-425 that I am using to switch several 120 VAC solenoids and to control the start/stop operation of a Durapulse VFD. The fieldpoint write VI does not output an error at all and the relay module will run perfectly for a inconsistant amount of time (10 mins to 2 hrs). Suddenly, all communication to the relay module will be lost and outputs that are closed will stay closed and open will stay open, but no control is available. There are no error codes and all other modules (TC, AI, AO, DIO) work fine. I am about ready to put this thing on ebay. Does anyone have any ideas? Thanks for your time,
0 Kudos
Message 5 of 8



Do you have snubbers installed across the coils of your solenoids?

0 Kudos
Message 6 of 8
I solved my problem by putting a MOV and noise suppressor across the relay.  If I had to redesign it, I would not use the cFP-RLY-425 module to switch 120VAC to actuate the solenoid valves.  Instead I would use the cFP-RLY-425 module to control another relay that will switch the 120VAC inductive load of the solenoid valve.
0 Kudos
Message 7 of 8
We installed MOV's across all of the AC solenoids and restarted the system. I was pretty confident this would work after reading the previous posts but my excitement was shortlived when, after about 40 minutes the same thing happened as before. Come to find out, after calling NI, our cFP-RLY-425 was recalled! I really hope this is the problem...
0 Kudos
Message 8 of 8