FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

error on executing when using FP-1000 and two FP-TC-120 modules

Go to solution


I have an error occuring in my LabVIEW program when closing the Field Point connections.


I am using LV8.5 and im connecting to a FP-1000 controller (RS-232 native port) which connects to two FP-TC-120 modules, under XP.


The error i get is 'Error 33589' caused by '', it is actually the second '' that produces the error as indicated in the picture by the giant arrow. Strangely it doesn't seem to have an effect of the program and it runs and disconnects as it should, its mostly just bugging me.


I can't find this error listed anywhere, nor can i find a nice long list of the errors.



I have a niggling feeling that when i close the FP read tags with the FPClose.VI i'm actually closing connection to the FP module and hence not closing the system down as was intended. 


I would be grateful is someone would instruct me as to the cause of the error, and what i should be doing to correctly close down the FP module. 

0 Kudos
Message 1 of 5

You have a path that you are splitting in two and opening up in two different FP Opens.  Why?


Why are you repeatedly opening that path inside a loop?  You could potentially run out of resources and crash LabVIEW.  You should only open before a loop, do what you need to in a loop, then close after the loop.


The real clue is that you said "it is actually the second FP close that causes the error".  Because you are now closing the same reference as you closed with the other FP Close, that might explain the error.


Can you clean up your code some?  There are some wires hiding behind functions.


What version of Fieldpoint are you using?  Those FP icons look old to me, and don't look like the ones I have in my LabVIEW installation.

Message 2 of 5

I guess part of the problem is that 'I've always done it like that', I inherited a program which i think was based on the WebLogger example in verion 3.x of the FP software which worked and i have never really questioned.


The path to the IAK splits in order to create the tags required to access the two thermocouple modules. When i have tried in the past to get channels from the second module it only gives me the first module channels, perhaps my method of gathering data isn't correct?


I see what you mean about the continually opening the comms inside a loop. Actually it would explain some of the chronic performance i've experienced! 


I think the original was made using FP verion 3.x (it was certainly made with LabVIEW 6).


Based on what you've pointed out, i think i will start again with the FP logging VI. I will let you know how i get on.



Is there somewhere that has a list of FAQ's for using the FP? I've looked (from Google) but not found anything for FP only for cFP that doesn't seem to give an idiots guide to creating FP VI's



0 Kudos
Message 3 of 5

Ravens Fan is correct.  The root cause of your error is the fact that you are opening two sessions with the same .IAK file.

0 Kudos
Message 4 of 5
Accepted by Vannystick

Well I managed to get to the bottom of the problem, it was not caused by FPClose!


The errors where obviously being cascaded through FPClose and while the 'error out' stated that the source was the second 'FP' it was actually from the second 'FP'. The fact that the IAK was in a loop was not the cause of my problem, however it is a clear sign of poor programming!


FieldPoint Read Error 33589 actually relates to the fact that some channels are deteremined to be OpenLoop. In my case i had all channels of the first bank connected to K-Type thermocouples, but only 2 channels of the second bank connected, and hence the error arose in the second 'FP Read' and cascaded to the second 'FP Close'. To consider it an error is actually a misnomer as it is actually a warning and does not have an influence on the running of the program.


I believe the original example I posted was written for LV 6.1 and FP 3.x. I have updated my own example to the updated methods used in LV 2011 and FP 6.0.9, they run much smoother than the previous method! Hopefully this might help someone else in the future.

Download All
0 Kudos
Message 5 of 5