FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

communication failure

Solved!
Go to solution

Hi

 

I have a loop that is acquiring a lot of FP and cFP devices and writes it's values into Global variables. 

From time to time an error occurs and all I have to do is rereading the FP IO Global that are defined in my project file.

Why does this happen and what can I do against it?

 

 

Yves

 

PS: The reason I use Global Variables is that I need to access to the data from dynamically loaded, referenced vi's. 

0 Kudos
Message 1 of 18
(7,734 Views)

Hi Yves,

do you get an error message?
What LV version, which driver and fieldpoint do you use?
Thanks for the additonal information.

best regards
Alexander
0 Kudos
Message 2 of 18
(7,704 Views)

I'm using LV8.6.1 with Fieldpoint driver 6.0.5 on a WinXP computer.

In fact I'm getting  a 33162 error. But strangely I didn't had this sort of error earlier. And I haven't change this part of the application.

 

Is my acquisition loop  running to fast? I have set it to 20ms.And the error actually occurs every few hours.

 

I'm using FP1001 and cFP1808 controllers with several different module  (AI-110, AI-111, AI-112, DI-301, AI-100) 

 

I also have some CTR-502 and DO-401 connected on the controllers but the writing is not running in a this subvi.

 

Hope these information will help.

Thank you.

 

Yves

0 Kudos
Message 3 of 18
(7,700 Views)

Hi Yves,

 

yes the fast collection of the signals can be the reason. There are some knowledge articels about it

What Happens if FP Read is Called and the FieldPoint Network Module is Offline?

Error 33162 with FieldPoint Ethernet Module

setting the time a little bit higher, will help to get no error.

 

best regards
Alexander
0 Kudos
Message 4 of 18
(7,696 Views)

Hi Alex

 

Thank you for your help. I hope this KB will be the right one.

 

I read the document and have one question about this:

 

I don't use RT (since I have cFP1808 controllers). I only can set the "Timeout" which is actually 0ms.

But does this value have any meaning if a have the network watchdog configuration set to "Disabled for bank"?

 

And if I set this value to 20ms does this mean that everytime I make a reading or writing to a channel the module will wait for 20ms? I'd say no, but I'm not sure since I haven't worked with this timeout yet.

 

 

Yves

 

 

PS:  I have checked the error logs and found out that there were no more errors with the FP-1001. The errors where only produced by the cFP-1808 controllers.

0 Kudos
Message 5 of 18
(7,678 Views)

Hi Yves,

 

if you have disabled the network watchdog configuration the timeout will not have an effect.

Is the timeout enabled and entered and you read or write to your Fieldpoint an value and 

the device do not response in this timeframe, you get then an error. The timeout do not

delay your message the values will sent immediatly, the timeout only controll the timeframe,

when the fieldpoint should be answer.

 

Have you tested it with this function and a value like 1000ms?

best regards
Alexander
0 Kudos
Message 6 of 18
(7,672 Views)

Yes, I have tried the network watchdog.

And I have changed the data reading and writing. Now I do every writing and reading in a single subvi. 

All modules of a controller are read and written sequentially (first module, second module, ...). This way there shouldn't be to many requests.

 

And the error still occurs from time to time (approximately every 30 minutes)

I have also changed the network adapter on the host computer.

 

I'd say it is a network problem because the same program runs some older FP-1001 plus modules connected through RS232 and I don't have those extremely annoying connenction failures.

 

Any idea?

 

All cFP-1808 have a 192.168.1.xxx IP adress. The subnetmask is 255.255.255.0, no gateway but the DNS-Server is automatically set to 90.0.0.3. Might this be a problem?Is it possible that some sort of DNS-Server searching is causing the problem?

 

Thanks for any help. I'm really desperated.

 

Yves

0 Kudos
Message 7 of 18
(7,476 Views)

Edit: The error is also generated in shorter delays

Sometimes one minute, sometimes 10 minutes...

0 Kudos
Message 8 of 18
(7,469 Views)

Hi Yves,

 

have you tried to upgrade the firmware?

cFP-180x Firmware 6.05 - Windows 2000/XP

 

What network adress will you get, if the DHCP is giving you automatically an adress ?

How to Network FieldPoint to a Host Computer with Ethernet

Set the option in the MAX to obtain an IP Adress automatically and make an IP reset with your device.

 

best regards
Alexander
0 Kudos
Message 9 of 18
(7,456 Views)

Hi

 

First of all thanks for your help.

 

The firmware is 6.05. and I obtain a DHCP adress. Although I have set a static IP-Adress now. I have now filled out the DNS-Server, the Time-Server and also the gateway.

 

Sooner I thought it is network problem but now that I have set everything on the controller I'm more and more sure that it must be some code portion that creates those problem.

Although I can't image which on because I don't do any communication with the FP-controllers anywhere else than in one single vi.

 

But when I have this single vi running for tis own I don't see those communication failures! Even after hours. 

 

And when I start the other vi's (and there's really no communication to the controllers in them) I got the errors.

Well now I'll start to have a closer look to the priority settings of the vi's...

 

Yves

0 Kudos
Message 10 of 18
(7,442 Views)