FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

cFP-PWM-520 ch0 was working then stop can not get any PWM signal

I was using the cFP-PWM-520 to control a H-Bridge(with higher current capability). I was getting eraric output of the H-Bridge, while checking I found the +24VDC input into H-Bridge loose an proceded to tie the screw down to secure the wire.

While doing the work my screw driver slip of my hand an shorted the +24VDC line with the heat sink of the +12VDC power supply of the H-Bridge circuit creating small spark. The signal input from the PWM-520 is 3 inches from the +24VDC input. I replaced the 2 chips in the H-Bridge board as a precoution.

I procced to turn the PWM ON to test the H-Bridge but now I do not get a PWM signal. I disconected the PWM-520 from the H-Bridge still no signal, looking with the scope sometimes get some pulses then either goes full high or full low, then it shows iraric pulses. I had allready reboot, reload labview into the CFP-2220, changed channels (same results no pwm). The rest of the FieldPoint works fine.
Do you have any idea I can try. Even do I think I allready know the cFP-PWM-520 is dammage even do it is protection against shorts.

 

Using LabView 12 SP1

cFP-2220

cFP-PWM-520

0 Kudos
Message 1 of 2
(3,824 Views)

Have you tried placing the module in another slot and seeing if it works? Is the ready light on? The cFP-520 manual describes the proceedure for resetting a channel after a short circuit occurs, have you followed these steps yet?

 

See the bottom of page 6

http://www.ni.com/pdf/manuals/373357e.pdf

 

Hope this helps!

Rob B
FlexRIO Product Manager
0 Kudos
Message 2 of 2
(3,795 Views)