FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

cFP-2120 not found in MAX, how to manually reformat/ghost

I have a cFP-2120 that gave me the following message everytime I tried to deploy:
cFP-2120@0, Bank is not responding or module not found.
I decided to reformat the 2120 but MAX could not find it. At this point I could still FTP into it so it had a valid connection. I  tried a dozen times to boot into safemode and eventually trying to reset the IP address so MAX could find it. At some point the IP address did reset and I could no longer FTP into it, I checked and double checked everything (IP addresses, crossover cable, no firewall, etc.) I decided to see what console out (pin 5) would give me and now everytime it displays the following:
Kernel Panic: VFS: could not mount root fs @ 01:00
I put in a service contract with NI and I'm waiting to hear back. I believe I'm to the point where I need to manually reformat the internal compact flash memory or possibly ghost the image of another cFP-2120 system onto this one. Does anyone know if this is even possible or how to go about it? What about voiding any warrentys (it's two years old) if I have to send it in? Thanks for your help.
0 Kudos
Message 1 of 4
Hi THX108,

If you are Lee, then you have an active service request (#7204643) with Karunya.  I sit next to her, and we took a look at your forum post together.  You should not attempt to, "manually reformat the internal compact flash memory or possibly ghost the image of another cFP-2120 system onto this one".  Attempting to do so will void the warenty of the system.  Karunya was waiting to hear from you if the RMA would be approved by the project supervisor or not.  When you are ready to process the RMA, please give us a call at 866-ASK-MY-NI.  I hope this helps.
0 Kudos
Message 2 of 4

Hi Steve,

This is Lee who talked to Karunya who is very nice and helpful. I looked into the warranty and unfortunately it is already expired, it's over two years old. I looked into sending it in for repairs and was told it would cost %50 of the price of a new unit. I am currently looking at the low-end cFP-2220 which would be right at this price and is twice as fast. I would still be interested in learning how to fix this unit since it will probably be shelved, that way we could have a backup or use it for prototyping. I'm the furthest thing from an expert, but from my observations it looks like the only thing wrong is the internal memory is corrupt to the point MAX can't communicate with it. I was looking in the National Instruments folder and found an "RT Images" folder, does MAX just copy these files over or is the process more complicated? If anyone can help that would be great. If it's inside information or getting into proprietary territory then that's fine too. Thanks.

Message Edited by THX108 on 07-28-2008 08:19 AM
0 Kudos
Message 3 of 4
Hi THX108,

You can replace or update the firmware on some FieldPoint controllers from Measurement and Automation.  If you click on the controller in the Remote System section, you will get a Firmware tab if the unit supports this feature.  Unfortunately, the 2120 does not support this feature.
0 Kudos
Message 4 of 4