FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

cFP-20xx minimal software

Hello,

what is the absolute minimum of software installed inside cFP-2000?

I use LV 8.5.1, the last allowed version for cFP-2000.

Are there other limitations in older Versions? LV6.1, 7.1?

What are the purposes of the parts?

FP Drivers?

FP VIManager?

LV Realtimemodule?

NI Watchdog?

 

 

0 Kudos
Message 1 of 3
(5,496 Views)

Hi Theo1,

 

as you stated correctly LV 8.5.1 is the last version that supports the cFP-2000 system.

There aren't any limitations regarding FieldPoint with older LabVIEW versions in general, but not all FieldPoint driver versions are supported by older LV-versions, so the restrictions mainly result from the driver you're using.

 

The minimum installation for FieldPoint is:

  • FP driver
  • FP VI manager
  • LV RealTime
  • NI Watchdog


The FP driver is needed to recognize and configure the device, the driver also includes the programming API. As the cFP-controller runs an Real-Time Operating system you will need the LV real time module to be able to program it.

Further information regarding the NI watchdog can be found here and here

 

Hope that answers your questions. 

 

Regards,
Bernd

 

 

0 Kudos
Message 2 of 3
(5,474 Views)

Hi!

   Watchdog is not mandatory, you can run succesfully your applications without installing it on cFP.  Actually, I don't know the steps to configure cFP in newer LV version, but in MAX based configuration, you can simply uncheck Watchdog software in installation page.

 

   About LV Realtime module, you need it to program cFP, i.e. to develop your own application and run it in cFP, so it is required.

 

   Hope it helps!

 

graziano

0 Kudos
Message 3 of 3
(5,377 Views)