FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

Unexpected Optomux Character with FP-1000

The setup of this FP-1000 and CTR-500 has been in place for 3 years. Now I can no longer communicate with any FP device on that computer. I have tried changing COM ports and FP-1000 and CTR-500 modules and I get the same response with all configurations. One window will tell me that "unexpected Optomux commands received" another will state "timeout occured" and yet another tells me "Possible Operating System Error". I tried updating the firmware but the program will not recognize any deivce on any of the channels. Does anyone have a clue where to start?
0 Kudos
Message 1 of 6

The "unexpected Optomux commands received" error will be reported when the FP-100X module is unable to properly interpret a command message. The "timeout occured" message will occur when the computer does not receive a response from the FP-100X module. Both of these messages point to problems in the serial communication layer. Likewise, the inability to recognize the devices also indicates that there is no communication between the computer and the FP-1000 module.

When we add in the "Possible Operating System Error" message, it makes me suspect that the serial port hardware on the computer has failed, or the serial port driver has become corrupted.

As a starting point, I would recommend that you try communicating with the FieldPoint units on a diff
erent computer (move the serial cable to a new computer). This allows us to rule out the FieldPoint hardware. Given that you have tried other FP-1000 modules, I would personally rule FieldPoint hardware failure as extremely unlikely.

You can try using Hyperterminal to communicate with the FP-1000 module by typing in some of the Optomux commands as they are documented in the FP-1000/1001 Programmers Reference Manual. Assuming that the second computer works fine, but you are unable to talk with the FP-1000 from Hyperterminal on the first computer, then I would try to re-install the serial driver on the first machine and test communications again.

If it is not possible to re-install the serial driver, you may want to consider backing up the hard-drive and re-installing the Operating System. If you re-install the OS and it still does not work, then it is likely that the serial port hardware has failed.

0 Kudos
Message 2 of 6

Hi Aaron

I have a similar problem. Just this morning I changed a computer. Now running the same program, with the same drivers I also get the error -33816 (Unexpected character received from Optomux response).

But I do have one big difference: Generally it works (for over 1h) and out of a sudden I get the error. Are there still the same recommendations for solving this problem or is there anything new?

Thanks in advance.


Using LV8.0
Don't be afraid to rate a good answer... 😉
0 Kudos
Message 3 of 6

An "Unexpected character" message generally means that one or more of the characters in a message string was corrupted. The primary cause of this on serial lines will be improper termination or noise. For RS-485 communications, you should be using two pair twisted shielded wire, with one pair having the Tx lines and the other pair having the Rx lines. The lines should be terminated at the source (computer) and the final transceiver (last FP-1001 on the line) with 120 Ohm resistors. The resistors should be placed between Tx+ and Tx- and Rx+ and Rx- (see page 8 of the FP-1000/1001 Quick Start guide pdf ). Note that with a multi-drop RS-485 configuration, it is recommended that a daisy chain configuration is used rather than a star topology.  Hope this helps.

Brian T
Applications Engineer
National Instruments
0 Kudos
Message 4 of 6

Hi Brian

As I use RS232, this won't help. But obviously it must have been a driver based problem. The port which I used is on an extension card (4 additional com ports). As one more try I used another com port (also on the extension card). This port seems to run without any problems up to know. Yesterday was no problem and what happened over night I'm gonna check right now.

Anyway, thanks for your efforts.


Using LV8.0
Don't be afraid to rate a good answer... 😉
0 Kudos
Message 5 of 6

Hello all

We got this error in a repeatable fashion by unplugging a non-functional UPS. It id due to dropping power to the fp1000.

Hope this helps.


0 Kudos
Message 6 of 6