FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble reading data from AI-118 and serial port data from a cFP-2120

Highlighted
I'm using a cFP-2120 controller on a 4-unit backplane housing 3 AI-118 modules and a TC-120 module.  Additionally, I'm trying to read data into the serial port (COM 1) of this controller (weather station data).  If I run the weather station by itself, it seems to work just fine.  When I try to run it with the rest of the software, it acts up, giving lots of communication errors and delays.  I have the same code I'm running as a standalone VI running in parallel with the code reading the AI-118 and TC-120 modules.  I've done this in the past on a different system and it seemed to work just fine, but this time around I'm not having the same luck.  The only difference between then and now is that I ran each as 2 separate VI's running in parallel before whereas now I've got the code in two parallel timed loops in one VI.

I'd sure appreciate a bit of help on this one.
0 Kudos
Message 1 of 6
(4,773 Views)
You said that you were using two timed loops.  Which loop has the higher priority?  If you swap the priority of the two loops, does the problem change?
0 Kudos
Message 2 of 6
(4,761 Views)
Sorry. but I didn't do a thing with priority, as it's not an issue for me.  This is a SLOW data acquisition system, with the temperature part (Loop 1)only capable of being read once per second, adn the Data Loop (2) being read onve every 1/2 second.
0 Kudos
Message 3 of 6
(4,748 Views)
What kind of communication errors are you seeing? 
0 Kudos
Message 4 of 6
(4,744 Views)
What are the error #s you receive?

-Bob

Message Edited by B O B on 08-08-2007 10:00 AM

0 Kudos
Message 5 of 6
(4,741 Views)
I'm sorry......

I did further investigating do to some other "characteristics" of the problem and found a second incident of one of the loops (a separate VI) sitting underneath one of my loops.  I deleted it and everything runs fine now.  Please forgive me my sudden loss of intelligence.
0 Kudos
Message 6 of 6
(4,733 Views)