FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

Simulating a current loop and load with cfp-aio-660

I will be eventually using my cfp-aio-600 to send a current control signal into a machine. Before I actually implement the cfp on the machine, I am trying to understand how to generate a current signal with my cfp-aio-600. I have the Current Output and COM sockets of the cfp-aio-600 hooked up to a 1 Kohm resistor. My cfp gets power from a 20vdc, 800mA source. My VI consists of a write to cfp vi connected in series with a control. When I run the VI, the VI runs without errors; however, when I try to measure the voltage drop across the resistor, my multimeter says that there is no voltage drop across the resistor. Also, when I run the VI, all of the analog output LEDs are red. What do I need to do to obtain a non-zero voltage reading across my resistor? Thanks for your time.

Message Edited by tquintana55 on 07-08-2008 05:21 PM
0 Kudos
Message 1 of 6
Your 1 kohm resistor is too large.  Look at page 15 of the manual.
It says it can handle a resistive load of 1 kohm for a 24 VDC supply.  But you have only a 20VDC supply.  According to the footnote, your maximum resistive load would be about 800 ohms.  I would recommend even smaller.  Perhaps a 500 ohm load.
Message 2 of 6
Thank you Ravens Fan for you consideration and time. I replaced the 1K ohm resistor with a 500 ohm resistor. When I run my vi, I receive the following error message:

error 33162 occured at FP
Possible reason(s):
FieldPoint:  Unable to connect to the data item on the module.
Possible causes: (1) A connection is broken, or (2) the network module is not powered on.

Again, all of the red LEDs on the the cfp-aio-600 are on. The green LEDs for 'power' and 'ready' are also on. My connections to the cfp-aio-600 are shown in the attachments in my orriginal post. I am using NI-FieldPoint 6.0.1 and I am connected to my Field Point using a crossover Ethernet cable. Any help would be greatly appreciated.
0 Kudos
Message 3 of 6
I see on your screenshot that you have a cFP listed at and a fieldpoint at  Do you have more than one piece of equipment?  Your pictures show a compact fieldpoint.  Is it a controller or just a network module?
I would recommend expanding each of those two items and see what devices they contain and what their network address settings are.  You may need to right click and do a find devices and settings.
By your code, you are trying to right to the FP version, but I would think that would be given the cFP name based on it being cFP modules.  And the FP device doesn't have an IP address assigned.

Message Edited by Ravens Fan on 07-09-2008 02:25 PM
0 Kudos
Message 4 of 6

Error 33612 can be caused for the reasons you have listed. One scenario is that your setup might be correct but the connection just times out because it does not receive a response from the modules. This knowledgebase explains this scenario in more detail and the solution to avoid this error.

The second post on this discussion forum are also more troubleshooting tips for you.

A few questions:
1. Are you connected using a crossover cable or a straight through cable?
2. Have you always had this problem?
3. Are you able to ping to the controllers/Ethernet modules address?

Answering the above questions along with answering RavenFans questions will help us to help you.

Warm regards,
Karunya R
National Instruments
Applications Engineer
0 Kudos
Message 5 of 6
I have solved the problem by giving the cfp it's own, static, IP address. In addition, I have connected the power supply in parallel with my aio-600 V and C terminals so that I can suppy the proper current. Thank you all so much for your help!
0 Kudos
Message 6 of 6