FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

Setup to communicate using Logos to Fieldpoint from PC

On a suggestion from the Lookout board I'm posting this here too.
I'm having a problem communicating with a cFP-2120 RT application using logos and datasocket.  I've read and tried to follow the instructions in the documents:
Developing a LabVIEW Real-Time Application for Fieldpoint
What are the different communication techniques using logos and fieldpoint
Deploying and launching a Real-Time Application
How to Allow Remote systems to create and write to Datasocket Items
Introduction to using Datasocket commands to communicate with Fieldpoint Ethernet Network Modules
Using Datasocket in LabVIEW Real-Time
But I still can't seem to get it to work.  I feel like I'm missing one piece of the puzzle.  Do you know of a comprehensive starting guide for this communication - PC running LV 7.1, ethernet connected cFP-2120 running a realtime app.  Datasocket commands in the PC .vi to read/write to logos items;'s in the RT .vi ... Items show up in Max...I don't know.  I want to avoid DSC if possible (I thought that I don't need that).  Any suggestions for starting out with this?  I feel like I've done it all but if anyone has some suggestions I will try them to make sure.
0 Kudos
Message 1 of 8

I have done something similar to this before. You don't need DSC. And if MAX is able to see the items, and show you the correct values, then there's no issue on the RT side.

On the PC side, are you getting any error with the DataSocket Read function? Also, make sure the URL is of the following format:



0 Kudos
Message 2 of 8
Hi Khalid,
I'm not getting any errors on the host PC's .vi.  I'm attaching both - logos is the host .vi and RT SerialModule logos is for the cFP.  As-is, it's not working.  I embed the application on the cFP, I reboot it so it runs, I start the host PC's vi, and it doesn't do anything.  Also I don't see any new created items in Max under Data Neighborhood.  Any ideas from here?
0 Kudos
Message 3 of 8
This is a link to an example program which performs the operation you are trying to achieve:
It should give you a good start on how to get this to work.
Best of luck,
0 Kudos
Message 4 of 8

Hi AG,

Thanks for the response.  I tried the program and it works!  That's the good news.  The bad news is that when I modified it to add a data going the opposite way (from the reader to the writer) I couldn't get that part to work.  The modified versions are attached.  I made a few notes while I did this exercise that I'll share here in case they might be important.

1. When I build the .exe / .dll file from the, I am told about the file "C:\Program Files\National Instruments\LabVIEW 7.1\vi.lib\system\Glogos.dll" that "Target OS has its own version of this DLL."

2. I don't see any items created in Max in Data Neighborhood, during/after I run either the original files you told me about or my modified ones, before during and after I Refreshed and closed/reopend Max.

3. In Max, when I click under the Data Neighborhood which is under Remote Systems-cFP 2120-Data Neighborhood (i.e., not the same Data Neighborhood as I mention in #2) I get the message, "Could not load item names from the remote system.  An unknown internal condition has occured.  Possible cause: unrecoverable operating system error."

Any suggestions?

Thanks again.

0 Kudos
Message 5 of 8
The reader VI can only receive data, while the writer VI can only send data.  I'm not sure I understand what you mean by "data going the opposite way (from the reader to the writer)" - what is it exactly that you are trying to achieve?
Regarding the error you are receiving on the remote systems in MAX, are you able to test the controller? does the controller work?  what software do you have on the controller? have you upgraded the software recently?
0 Kudos
Message 6 of 8
Hi AG,
Data transfer between a PC and a Fieldpoint can be 2-way - data from the Fieldpoint to the PC and also data from the PC to the Fieldpoint, for example if you want to control a valve or a relay or whatever you need to send the data from the PC to the Fieldpoint.  As written, the original .vi you referred me to can do the first but not the second.  So when I say that I modified it to get the data going the opposite way, I meant that I am trying to use the logos/datasocket method to send data from the PC to the Fieldpoint.  I'm doing this by using a "datasocket write" in the PC's .vi and a - Read configured in the Fieldpoint's RT .vi.  You can see this in the two files I attached in my previous post.  I hope this answers your first question.
Secondly, the example you referred me to works fine.  Also I can communicate with all my modules fine.  So I believe I have verified that the controller works.  As for the software versions, see this post, which I have followed regarding which versions I have installed on the controller.  One question I have remaining is whether I can use FieldPoint 5.0 with LabVIEW 7.1 on the PC.  From the post I just mentioned, I cannot do that on the RT controller.  But for the PC, everything seems to be working fine when I communicate with the Fieldpoint during normal operations (i.e. sending/receiving data to all my modules) when I use FieldPoint 5.0.  But could this be causing a problem with the logos?
0 Kudos
Message 7 of 8
This discussion finished on the lookout board here.
0 Kudos
Message 8 of 8