FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

Requested VI is broken and cannot be viewed or controlled.

We are currently running a cFP-2120 with cFP-AIO-610.   The unit has worked without any issues and have been able to log into it via the web to setup tests and confirm them.  Recently we have gone to the web address and the webpage opened, but the plugin for LabView states "Requested VI is broken and cannot be viewed or controlled".  I have disabled the IV and we get the same error.  I am able to FTP into the unit and look through the files without any issues.

 

Any suggestions to the issue this could be having? Is there a corrupt file?

 

Thanks,

Chip

0 Kudos
Message 1 of 6
(6,222 Views)
It might be a corrupted file. Have you tried simple troubleshooting steps like building a simple new VI and deploying that on a web server and opening it? What happens when you access the VI from a browser of another computer? Do you get the same issues?
Adnan Zafar
Certified LabVIEW Architect
Coleman Technologies
0 Kudos
Message 2 of 6
(6,211 Views)

I am troubleshooting a failed test stand and have never programmed before.  So I am trying to figure out where the error is coming with.

 

I have tried other computers and same issue.  I have contacted the programmer and hoping to get the files such that I can reload the machine.  From what I can see, it was pointing to a corrupted file.  What type of file would cause this error?  An .EXE or .VI  extension?

0 Kudos
Message 3 of 6
(6,198 Views)

Chip,

 

Judging from your level of experience with LabVIEW, I highly suggest reloading all of the files onto the cFP.  The error means that the VI you are trying to access is not runnable.  In a Windows environment, I would suggest to simply open the VI and fix where it was broken.  However, since the VIs are stored on the cFP as .rtexe files, they are no longer editable, and therefore you will have to reload the original source files from your developer.  

 

I am fairly confident that reloading all the files will fix your problem, but post back if you are still getting the error after transferring everything over via FTP.  

Sincerely,

Chris G in AE
0 Kudos
Message 4 of 6
(6,174 Views)

Do I need a special cable to go from the module to my lap top?

0 Kudos
Message 5 of 6
(5,117 Views)

Is your question related to what was discussed in this thread?  It sounds different and should have gotten a new thread.

 

You might need to use a cross-over network cable to connect your laptop to the compact Fieldpoint.

 

If you have more questions, please start a new thread with more details.

0 Kudos
Message 6 of 6
(5,110 Views)