FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

Requested VI broken in executable

Solved!
Go to solution

I created software that should run on a cFP system in LV 8.2. The Vi is deployed OK when running in development mode. It also builds into an executable without errors or warnings. Then the problem starts, the exe is not running on the cFP target. It states requested VI is broken when trying remote panel connection.

 

Is there a known issue that could cause this to happen?

Regards,
André (CLA, CLED)
0 Kudos
Message 1 of 5
(5,879 Views)

Hello Andre,

 

thank you for your post on our webforum.

 

I noticed a discussion thread which looks a little bit the same, so I hope this thread is useful to you;

http://forums.ni.com/ni/board/message?board.id=170&message.id=292199&requireLogin=False

 

What version of NI Fieldpoint are you using? I noticed some problems with NI Fieldpoint versions before 6.2. Which controller are you using? Is the problem occurring with only one project, or is running a executable impossible at this moment?

 

Best regards,

Martijn S
Applications Engineer
NI Netherlands
0 Kudos
Message 2 of 5
(5,860 Views)
The application is propably using FP 5.x drivers at the moment. It has no classes as in the linked post. However it is using shared variables to read from and write to. The shared variables are defined in the project and are deployed explicitely by the PC application. Could there be some relation between this and a broken exe?
Regards,
André (CLA, CLED)
0 Kudos
Message 3 of 5
(5,858 Views)
Solution
Accepted by topic author andre.buurman@carya

Hello Andre,

 

Thank you for your response. There are three methods for binding a fieldpoint channel to a shared variable, please note that with the second method; 'Therefore if you are using LabVIEW 8.2.1 or earlier, you cannot build executable files when using this method that will work with only the LabVIEW Runtime Engine' . The first method is recommended.

Which controller are you using? I suggest you are using NI Fieldpoint 5.0.1 since the 5.0 version isn't suitable for 8.20. Is ths problem with only this project, or do you ave the ame problems with other projects (containing the shared variables) If the knowledge base I mentioned isn't the solution, can you attach a example to reproduce this problem?

 

Best regards,

Martijn S
Applications Engineer
NI Netherlands
Message 4 of 5
(5,855 Views)
Thank you for the info regarding updating the drivers. After updating to FP driver 6.0.3 the executable ran correclty.
Regards,
André (CLA, CLED)
0 Kudos
Message 5 of 5
(5,762 Views)