FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

READY light not lit and problem with MAX

I have a monitoring system based on one FP2000 and 3 modules 1 digital and 2 analog input FP-AI100.
It has worked several months and has failed suddenly.

Now the situation is as follows:
The FP2000 status LED blinks 2 times; the ready LED of both the FP-AI100 does not lit.

Trying to connect through MAX I can see the FP2000 but fail to access to the other modules through the find device request. The error message is timeout. Even the digital module cannot be reached although it has both LED power and ready lit.
I try to remove the modules and reinstate them with no effect, no pins seems damaged.

This application was developed externally and I am no expert with Labview and the kind.
How can I get this working again? And what can possibly happen to trigger such a failure?
0 Kudos
Message 1 of 6

Per Troubleshooting, Appendix C of the FP-2000/2010/2015 User Manual, linked here: , 2 Status Flashes means that the software of your FP-2000 has become corrupted. There are a number of reasons why the firmware may have become corrupted. The most frequent cause is a power failure occuring when writing to the Compact Flash. You will need to re-install the FP-2000 firmware.

The corrupted firmware is the reason why the FP-AI-100 Ready LEDs are not lighting and why you can not see the IO modules from MAX. Reinstalling the software will allow the module to fully boot at which point it will configure the IO modules, causing the READY LED to be lit. As a side note, the DI-300 series and DO-400 series modules will always light their Ready LEDs when not configured because they do not require any configuration.

0 Kudos
Message 2 of 6

Il s'agit d'un problème connu qui peut être définitivement résolu en suivant la procédure suivante :

N'hésitez-pas à me tenir informé.

0 Kudos
Message 3 of 6

Ceci dit, avant de lancer cette procédure, je vous invite à lire attentivement la note suivante :


0 Kudos
Message 4 of 6
I have tried to reload the driver as proposed but it has not changed anything at all.
I have now no more warning signs on the software page in Max but still I cannot find any devices (Timeout still) and the ready light of the FPAI are not ready. The FP200 status blinks 2 times.

0 Kudos
Message 5 of 6

Je pense que cela risque d'être difficile à dépanner par e-mail.

Je vous invite à contacter le service technique de National Instruments au 01 48 14 24 24 afin que vous puissiez en discuter de vive voix avec un ingénieur d'application.
Vous pouvez aussi envoyer un mail via

Même si vous n'avez pas de contrat de maintenance auprès de National Instruments, vous avez une période d'essai de 30 jours pendant laquelle vous bénéficiez d'un accès direct au support technique.

Profitez-en, à moins que vous ne l'ayez déjà fait.


National Instruments France
0 Kudos
Message 6 of 6