FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

MAX error CmxExecutionThreadPool::DoWorkNonUI

Error occurs at MAX startup with CmxExecutionThreadPool::DoWorkNonUI.  Benign?   What problems will I experience? 

0 Kudos
Message 1 of 8
(9,332 Views)

Hello,

 

Would you mind posting some more information about your system including:

 

O/S:

version of Measurement and Automation Explorer:

NI FieldPoint driver:

FieldPoint hardware:

 

Thanks,

Patricia B.

National Instruments
Applications Engineer
0 Kudos
Message 2 of 8
(9,323 Views)

Hi,

I have experienced the same error!

 

O/S: winxp sp3

version of Measurement and Automation Explorer: 4.7.7f0

NI FieldPoint driver: no FieldPoint driver used.

FieldPoint hardware: no FieldPoint hardware used.

 

I have installed NiDaqmx device driver 9.2.3, nidaqmx max configuration 9.2.3, nipal 2.6.3, ni system configuration 1.1.3, ni pxi platform 2.5.6, labview run times 8.2.1, 8.6.1, 2009 sp1, 2010 sp1, measurement studio for vs2005 (dot net common 9.0.20.362)

 

Can you help us on that?

 

due to this error, I'm unable to view the daqmx devices. no daqmx (usb-6009), and no serial ports.

 

Thanks!!

 

0 Kudos
Message 3 of 8
(9,147 Views)

Hey Tobogan,

To fix this issue I would start by trying to install the Daqmx 9.4 drivers from www.ni.com/drivers.  This issue seems to be linked to a particular DLL that did not install correctly with Measurement and Automation Explorer(MAX) so reinstalling MAX usually fixes the issue.  The new version of the Daqmx driver is compatable with all the LabVIEW run time versions you have installed except for 8.2.1.  This means you would not be able to use any LabVIEW programs developed for LabVIEW 8.2 on your machine.  Please post back with any additional questions.

Kevin Fort
Principal Software Engineer
National Instruments
0 Kudos
Message 4 of 8
(9,137 Views)

Running a LV 2010. With NI-RIO 3.5.1, the only compatible version if I'm not wrong. 

When opening MAX I get the error message:

Context where exception was caught:

Func: CmxExecutionThreadPool::DoWorkNonUI Args: job=04FF4908

 

Further continuing with opening MAX , to add software to the rio, max says problems retrieving settings for the target, a NI cRIO 9075. 

Any fix`?

 

9075 not compatible with LV2010?

0 Kudos
Message 5 of 8
(7,932 Views)

Hello josens,

 

The cRIO-9075 was first supported in LabVIEW 2010 SP1 with NI-RIO 3.6.1 (You can see required versions here). If possible, install SP1 and get a newer version of RIO and you should be fine.

 

Ryan

Ryan P.
National Instruments | Systems Engineer | CLA
0 Kudos
Message 6 of 8
(7,887 Views)

Hi,

 

I recently tried to reinstall Labview 2010 on my computer. Previously it used to work but know MAX seems to have some issues : when starting MAX we get this error MAX error CmxExecutionThreadPool::DoWorkNonUI.

We tried to reinstall several times Labview but this error persists. Any idea ? Thanks a lot !

0 Kudos
Message 7 of 8
(4,817 Views)

it's a while ago ...  I newer really got a god exact solution or reason for this error. There were several issues for me with combinding new and old rios.

I think the peroblem was related to driverissues. The new Rio was not compatible with the MAX version etc.  My solution in the end was to upgrade to a newer SW.

 

 

0 Kudos
Message 8 of 8
(4,793 Views)