FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

IP address is not on the target's allowable access list.

when trying to deploy a lvlib or downloading code from a PC to a FP controller I get this error message "Access denied: This host computer's IP address is not on the target's allowable access list.". I have added the PC's IP address from within Max on the access list of the FP target (althoug default is full access to everyone). This did not help, I still get the same error message. Both systems are on the same IP segment.
søren h. jensen
0 Kudos
Message 1 of 15
Hi Søren,
There is a KnowledgeBase document that adresses this issue:
You can start with the Knowledge Base document to see, if it helps your problem.
If it doesn't you may also try to open ni-rt.ini in the FP root directory. Somewhere in that file is a tag called target.ipaccess, and you can add IP addresses (and wildcards) to that list. Then reboot the controller.
Best Regards
Dennis Morini
District Sales Manager
National Instruments Denmark
0 Kudos
Message 2 of 15

Normally the cFP or FP controller has no probling giving access to a PC without it specifically being on the IP list. Despite adding the PC on the IP list, I still get the same error.


Søren h. jensen

0 Kudos
Message 3 of 15
The problem was solved by reinstalling all installed (not the OS) software on the Fieldpoint controller. This fixed the problem an I can now again connect to the controller. I must however conclude that the problem never was solved properly, since I did not manage to locate the cause of the problem.
Søren Hallberg Jensen
0 Kudos
Message 4 of 15
I have experienced the same problem with the cFP-2120 controller.  I can connect all day long using MAX, but not in LabVIEW.  Once I reinstall all software on the controller, it seems to work again in LabVIEW.  But if the connection to the controller is lost, the problem will reoccur. 
-Derek Roane
0 Kudos
Message 5 of 15
I am also seeing the same problem.  Reinstalling all the software helps to connect again, but once I disconnect, I can't re-connect.  Can anyone help with this?

Message 6 of 15
Short of time right now, but I had the same problem: Here is a dump of my own notes on how I solved the pbolem (not necessary to reinstall software):

I attempted to update these data with Measurement & Automation Explorer (MAX) using the "FieldPoint Access Control" panel in MAX: I set "*" and Read/Write and pressed "Apply": MAX Claims it has updated the Access Rightsm, but we are still unable to Deploy the CFP from the Project Explorer.




Use WS_FTP-PRO (or any FTP Client) and access the IP Address of the FieldPoint using anonymous login.

Transfer the file ni-rt.ini from the root of c:\ on the Fieldpoint to the local PC and edit the settings as shown below.

FTP the file back to the Fieldpoint.


Set the following settings in "server.tcp.access" and "RTTarget.IPAccess":



NOTE: Double Quotes here


NOTE: Single Quotes here


+* means every IP address can access.



It turned out that MAX had left the following (probably illegal) values in the fields:

"""" and ""

Geir Ove
Message 7 of 15


   Nice fix.  I've spent the last 3 hours reformatting my cFP drive, and reinstalling the software (multiple times) just to be able just to reconnect to the target.  I wish I checked out this forum sooner.


0 Kudos
Message 8 of 15

Thanks for the help - that works great.  I've got an active support request with NI on the subject, so if I find out anything more there, I'll post it here.

0 Kudos
Message 9 of 15
I have been wasting a lot of time trying to deal with this same problem. Changing the ini file seems to be a temporary fix.  Is there any way to prevent the file from reverting to the wrong values? Every time I make a change to my real time code and try to deploy it I get the error message.  I change the ini file as described above and it will work until I have to make a change again.
0 Kudos
Message 10 of 15