FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

Getting an old fp-1000 back into action

hello everyone,

Our situation goes as follows: we have an old fp-1000 device attached to three fp-ai-110 along with some temperature sensors.


The overall system, as far as I know, was running smoothly in an old Pentium-II computer with Windows 95 and somewhere in 2004
stopped working due to unknown reasons. We tried to get it back working but we don't get any indication of temperature in the
software MAX accompanying the device (in Windows 95).


Our ultimate goal is to revive the overall system by migrating it in a newer computer, and we need some advice on how we must get
started. For example, newer computers don't have RS-232 ports, so we need an adaptor, and a compatible LabView version.

Moreover, as I mentioned, we don't get any indication in MAX and don't know what is to blame. Maybe the RS-232 link is problematic,
the software configuration on the computer or the fp-1000 itself. The power led is lit on fp-1000 but the others are not.
What strategy should one follow in order to test the system and see what is functioning or not ?


One thing I will surely try is to give optomux commands through HyperTerminal, and see if FieldPoint responds. But have never done it
before and don't know the prerequisites (any special optomux driver ?).


For now, I need the steps an experienced person would follow in order to ensure that the system is functioning, and any help would be
greatly appreciated. The migration process will take place in a second phase.


Thank you in advance.



0 Kudos
Message 1 of 12

Hello Dimitris,


Firstly, I would like to emphasize that since the FieldPoint-100 is an obsolete part, it is no longer supported by National Instruments, and is therefore not guaranteed to work. With that being said, I will give you what information I can in hopes that it will assist you.


When you mentioned that you, “don’t get any indication in MAX…” what do you mean? Are you unable to see your device in MAX, are you unable to add it as a device, etc.?


When you first power your device on, do you see the “ACCESS” and “STATUS” LEDs flash once, or do they never light up at all? In order to determine what the behavior of the LEDs on your FieldPoint device mean, refer to the “LED Indicators” section of the resource I have provided below.


FP-1000/1001 User Manual


I strongly recommend using this manual as you try to get your FieldPoint system up and running; it has a lot of information about how to set up your system. It is a searchable pdf, so it is very easy to look for what you need within the manual.


What OS will the newer computer you want to migrate to be? That will determine what software you will be able to use with your FieldPoint hardware.

The next resource I have provided includes a lot of resources for FieldPoint devices, including software compatibility, driver versions and a lot of other useful information.



National Instruments Applications Engineer
0 Kudos
Message 2 of 12

hello Gabby,


I apologize for the late reply but we were on Easter vacations, the school was closed and there is a obvious need to recheck a few things in respect with our issue.


When I mentioned "don't get indication in MAX ..." I meant the real-time I/O Data in their respective channels, where we can rename, test, see the address etc.
Are we supposed to see some indication there if the FieldPoint works and under what conditions ?


Just the POWER indicator is lit, ACCESS and STATUS don't flash at all.


Please don't answer right away, because I have to gather more info.


I will repeat this post more clearly, and catch up with you having more questions as I have to do some rechecks during next week.


Thank you for the understanding.


0 Kudos
Message 3 of 12

Hello once again,

We did the rechecks today and I have to state three points:
1) The part of the software we expect some indication of temperature (in terms of voltage) is called "FieldPoint Explorer" (ver.
2.0). During our attempt to get an indication we replaced the RS-232 wire with that of an old V32 modem. Please see image 1 attached.
2) We don't see the device in device manager (Image 2).
3) ACCESS and STATUS leds do flash once when I power up the device. I hadn't notice that.
4) The OS of computer after the migration process will be Windows XP.

So my questions, now,  are:
1) First of all, how can we tell which FieldPoint we have ? I suppose that because MAX is not present (I apologize if I mistakenly
call it that way) we have version 4.0 at most, right ?
2) Should the RS-232 wire be special or the one of the V32 modem is okay ? Some of the inner cables of the wire were broken, that is
why we replaced it.
3) I tried to connect to the device using HyperTerminal taking into consideration the baudrate is both sides, with no luck. How is
this possible to happen and send a basic command ?
3) Any ideas on how we can keep testing and reach our ultimate goal ? Or maybe this is not attainable ?

Thanks again,

Download All
0 Kudos
Message 4 of 12

Hi again,


I apologize for my insistence but we are very confused on what should be done. Can anyone please answer at least some of the questions ?

Thank you.


0 Kudos
Message 5 of 12

Hello Dimitris,


To answer the questions from your last post:


  1. You could check to see what version FieldPoint software you have by searching for it within Windows Explorer on your computer, or you could download NI MAX onto your computer and see what FieldPoint software is listed underneath the “Software” tab. The version of MAX that you install will depend on your OS and the version of LabVIEW that you are using.
  2. I am not very familiar with V32 modems, but within the FP-1000 User Manual, the following is stated: “Connect the RS-232 port of the FP-1000 to your host computer’s RS-232 port. Use a 9-pin DSUB male-to-female straight-through cable. Do not use a null modem cable (usually female-to-female)”. While a V32 modem is not inherently incompatible, it is not recommended for use with this device. The only type of cable recommended and supported for use with this device is a 9-pin DSUB male-to-female straight-through cable.
  3. Considering that your V32 modem may be causing the communication issues you are experiencing, I first recommend that you implement a supported cable into your system and then proceed with trying to send basic commands to your FP-1000.
  4. I am not entirely sure of how to test your system, considering that this product is no longer supported. There is very little documentation regarding obsolete FieldPoint systems, so it is difficult to troubleshoot this issue. Your ultimate goal is not necessarily unattainable, but the obsolescence of your hardware makes it difficult to troubleshoot, research, etc. The best recommendation I can make is to refer to the “Getting Started with FieldPoint Explorer” section of the FP-1000 User Manual on pages 4-7 through 4-11. I have provided a link to the User Manual below:


FP-1000/1001 User Manual


While testing your system and trying to monitor whether or not it is functioning correctly or responding to commands, I recommend monitoring the LED’s on your FieldPoint-1000. The behavior of the LED indicators on your device can describe various states of your device. For more information over the behavior of your LED indicators, please refer to pages 3-7 and 3-8 of the User Manual.


Considering the obsolescence of your device, I would not recommend setting up a new system with the FP-1000. There are many products that National Instruments offers that will allow you to measure temperature. If you are interested, I encourage you to look through the resource I have provided below; it discusses various types of NI products available for measuring temperature.


Temperature Measurements


I wish I could provide more specific instructions as to how to proceed, but the lack of support and documentation for this device make it very difficult for me to recommend what you should do moving forward. Please let me know if you have any questions moving forward and I will do my best to answer them.

National Instruments Applications Engineer
0 Kudos
Message 6 of 12

Hello Gabby,


Some little progress was made, but we're going to need your help once again since you are much more experienced than I am. Smiley Happy


We tried to operate the device and realized that READY led indicator is indeed lit on the modules. NETWORK led is flashing repeatedly on fp-1000 when we start monitoring, so according to manual is getting some data from the host. However, we don't get any temperature in FieldPoint Explorer and the Status field say "The timeout period has expired".


I searched this message and figured out that it can have various causes, which tried to eliminate one by one. Among othersI tried to extend the timeout limit with no luck. I also tried to create new configuration, carefully reading the instructions from the manual as you proposed, but device is not discoverable (while pressing the "Find Devices!" button).


One thing that troubled me is whether device is shield from interference. As far as I know, it was manufactured before the widespread emergence of mobile phones and wi-fi. According to this document, it may be the cause. What do you think ?


Thanks once again.



0 Kudos
Message 7 of 12

Hello Dimitris,


You may be getting the error about the timeout period expiring because your module(s) could be going offline. I have provided resources below that discuss this possibility:

What Happens if FP Read is Called and the FieldPoint Network Module is Offline?

Archived: FieldPoint Error Codes 32828, 32900, and 33152 Definitions


Considering that the NETWORK LED on your FieldPoint controller is flashing, it could mean that the connection is periodically lost during transmissions from the Host. From the manual, I get the impression that the NETWORK LED is supposed to stay lit while receiving transmissions for the host, therefore the flashing behavior you are experiencing does not appear to be expected or documented. I would double check that the transmissions from the Host computer are properly being sent to


Also, I think it is important to note the behavior of the ACCESS LED. According to the FP-1000 manual, “The yellow ACCESS LED flashes when the FP-1000/1001 or any of the I/O modules in its bank respond to the host computer. This LED indicates that a module in the bank was addressed by a correctly formatted command, and that the module is responding to that command (either with a success or error response).” Based on the behavior of the ACCESS LED, you can determine if any of the modules in the bank are responding to commands sent from the host.


Interference in the serial communication, whether it be from Wi-Fi, mobile phones, noise, etc. could be causing the issue you are seeing. I think it would be beneficial to first make sure that the commands you are sending to the modules in your bank, and to make sure that the baud rate, number of bits, etc. that you are sending are properly formatted.

National Instruments Applications Engineer
0 Kudos
Message 8 of 12

Hello, me again. 🙂

Before we give up and turn into another solution, I would like some more advice to give it a final attempt.

On the rear of the PC the port indicated as COM2 is actually COM1. FieldPoint responds on COM1, but cable is connected on COM2 (!). Maybe computer manufacturer mistakenly named the ports of the PC, maybe.

NETWORK led is flashing repeatedly as before when I start monitoring through FP explorer (I can attach a video if needed). I removed some fp-ai-110 modules and left only one to see what happens. Device is still not discoverable and I get a not that helpful message saying "Unknown error on FieldPoint server" (both in Status and while discovering). I also checked whether resistors are okay (they are all the same, none is burnt).


I believe address and baudrate are also okay.

Please, any ideas ?


0 Kudos
Message 9 of 12

Hello Dimitris,


What do you mean by, “FieldPoint responds on COM1?” Are you sending commands and/or data to COM1 and seeing an appropriate response?


If you plug your FieldPoint into the COM1 port of your computer, what happens?


The fact that your “Network” LED is blinking is concerning. This LED should stay solid and lit when there is any network transmission. This behavior could be indicative of a few things; in order to determine what could be occurring, I have a few questions.


  1. What behavior are the Power and Ready LEDs exhibiting? (Color of LED, lit/not lit, blinking/not blinking, etc.)
  2. I know that you checked the resistors on your device, but are there any other portions of the hardware that may be damaged? (Bent pins, etc.)
  3. What is the firmware revision of your hardware? (To determine the revision, go into FieldPoint Explorer, type “Revision” (without quotations) as the device name for the network module in the Device Configuration window. The revision version should then be displayed in the top, right-hand corner of the window.


Once I have some more information regarding this behavior, it will be easier to continue troubleshooting the problem.

National Instruments Applications Engineer
0 Kudos
Message 10 of 12