FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

Frequency in cFP CTR 500

Hi, I got a VI to read frequency from cFP 2020 with the CTR-500 module (Frequency in NI Example Finder. When I run this VI in LabVIEW for Windows, it's all right. But I want to run it embedded selecting the target and, when I do it, I cannot read the frequency. Does anybody knows what could be happening? Thanks
0 Kudos
Message 1 of 6
Hello Ietreca,

When you say you are running it embedded, do you mean that you are targeting the cFP controller, or downloading it to the controller and having the VI run when you reboot the cFP controller?
How are you viewing the VI front panel (from the host computer, from a remote front panel, from a web browser, etc.)?
Also, can you be more specific about what you mean when you say that you cannot read the frequency?  Does this mean that the VI doesn't run, the VI runs but no frequency value is returned, etc...?

DE For Life!
0 Kudos
Message 2 of 6

Hi E.Lee,

I tried to do the two things: selecting the cFP controller target and download it to the controller.

But I wish to download it to the controller and acquire the data from a TCP connection, and view the data in the host computer. The VI runs rightly when I run it from the host computer. But when I try to run it selecting the the cFP controller targeting , or downloading it to the controller and having the VI run when you reboot the cFP controller, the frequency returned is wrong (for example: running in the host computer the frequency returned is 2500 Hz. Selecting the cFP controller target and running the same VI, the frequency is between 5 and 10 Hz !!


Any sugestion will be appreciated

0 Kudos
Message 3 of 6
Hello Ietreca,

Have you noticed any other VIs behaving differently when you run them embedded on the controller?
Can you test one of the LabVIEW examples that installs with the Fieldpoint driver to see if you get the same behavior?
Could you post your code so we can test it out and see if we get the same behavior?

DE For Life!
0 Kudos
Message 4 of 6
All other VI's that I tryed to run embedded on the controller or on the host run rightly, so I don't think that there are any problem with the driver.
I hade post the code, Ok?
Thank's for the help.
0 Kudos
Message 5 of 6

Hi letreca,

I took a look at your code and it doesn't look like anything is really wrong there.  There was one thing that I think might help you.  Because you do not have any sort of data dependencies, you could be causing a condition where you are resetting the counter before you read it.  The best way to change this would be to connect the error out of the with the error in of the

You mentioned in your first post that you were using Frequency from the example finder (Browse > Hardware Input and Output > FieldPoint > Advanced); however, the code for looks completely different.  If you run the example do you get the same behavior? 

I think you may be having an issue mentioned in the first paragraph because you may be resetting the counters too early.  Try the example and if that works, use the same technique.  If that doesn't work, then try to modify your existing code as described.  If neither works tell me what has changed and what hasn't so I can try to take a closer look into everything.


0 Kudos
Message 6 of 6