FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

FieldPoint I/O Data Type versus Fieldpoint I/O Point Data Type

I have upgrated a project from LV 8.5 version to LV 2011 the Fieldpoint Data Types are different in LV 8.5 it is FieldPoint I/O and in LV 2011 it is Fieldpoint I/O Point. I built the proyect and tried to run it, no errors were present. Now the application can't read or write to the cFP-2100 controller module. In MAX i can see the controller, the modules and the channels both under Data Neighborhood and Remote Systems.

 

Setup:

 

Controller and Host Drivers: Field Point 6.0.10

Labview engine 2011

 

Here's my cluster in both LV versions

Fieldpoint datatype.JPG

 

 

 

0 Kudos
Message 1 of 5
(5,368 Views)

Hi ulises.uribe.

 

 

According to the Fieldpoint driver readme, you need different versions of the driver for 8.5 to 2011 (The latest version that supports 8.5 is 6.0.8, which doesn´t support LV 2011. Could you confirm that this is the FP driver version that you were using in 8.5 (Fieldpoint 6.0.8).

 

You can check if the syntax changed between 6.0.8 and 6.0.10 by creating a constant from one of the fieldpoint VI's and see if the syntax there is the same as the one in LV 8.5. Also, are the VI's that show up in the FP palette the same in both the 8.5 and 2011 versions?

 

Finally, you said that you can run your application in 2011 without any errors but it can't communicate with the cFP. Does the program ever throw an error? (Like a timeout error)

 

I'll check for more compatibility issues between versions once you confirm which version were you using in LV 8.5.

 

Regards.

 

Aldo H
Ingenieria de Aplicaciones
0 Kudos
Message 2 of 5
(5,339 Views)

Hi Alhern

0 Kudos
Message 3 of 5
(5,335 Views)

Hi Ulises.

 

Have you had any luck fixing the issue?

Aldo H
Ingenieria de Aplicaciones
0 Kudos
Message 4 of 5
(5,318 Views)

Sorry Alhern for the previous comment I had some troubles with our network.

 

Well I'd just create a new cluster with the new datatype labview version for Field Point and it worked. Definetly they changed the datatype from LV 8.5 to LV 2011.

 

to overcome this I'd recommend to replace all the old datatype with the LV 2011 Field Pont datatype.

 

 

0 Kudos
Message 5 of 5
(5,307 Views)