FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

Field Point OPC Problem with FP-PG-522

I am using a FieldPoint Pulse Generator module, FP-PG-522.  Using Measurement & Automation Explorer (Version 4.1.0.3001), I create a new Field Point Serial Interface on COM1, and my module is detected.  Under Devices and Interfaces, I then create On Time and Off Time Attribute items for channel 2, and save the project.

Using MAX to test, I select the FP-PG-522 module in the Data Neighborhood, and start the I/O data communication.  I successfully modify the ON and OFF time for pulse channel 2.

Now for the troublesome OPC server.  I exit MAX, start the Server Explorer, and use the Wizard to connect to the OPCFieldPoint.  Instead of displaying 10000 for the ON and OFF time written using MAX, 39 is the value displayed, although my pulses are still the correct rate. If I try to update these values from Explorer, I am limited to 8 bit values (ie: 266 becomes 10), even though the properties for the attributes reports an Item Canonical Data Type of 4-byte UInt.

This seems to be a Field Point OPC problem.  It's version is 4,1,0,15.  I applied the FieldPoint501 patch, but that didn't help.

TIA

0 Kudos
Message 1 of 6
(6,229 Views)
Rialto,

That sounds like it may be a bug.  I will try to get my hands on a FP-PG-522 and see if I can recreate the behavior you are seeing.  If it is compatible with the version of LabVIEW you are using, you might consider trying FieldPoint 6.0, which can be found on the latest device drivers download available on www.ni.com.

Regards,


0 Kudos
Message 2 of 6
(6,204 Views)

Thanks, Devin.

I am not using LabVIEW, but a VB app which interfaces to the OPC server.  I looked for FieldPoint 6.0, but could only find 5.0, which did not change my symptoms.

I have some other details.  This application is also installed on another PC, and it works there.  FieldPointOPC2.exe is an older version, 4.0.0.21.  I tried to move the exe, but the Server Explorer could not connect to it. I suppose it needs to be uninstalled / reinstalled, but I don't know how.

0 Kudos
Message 3 of 6
(6,197 Views)
Rialto,

I tested out a setup like you described in your original post and was unable to reproduce the behavior you were seeing.  When I run my tests, the values in Server Explorer show up correctly as 10000.

I am using the same FieldPointOPC2.exe version as you (4.1.0.15), with Server Explorer 2.4.1.  I am using FieldPoint 6.0 and Measurement and Automation Explorer 4.3.  You can download FieldPoint 6.0 as part of the August 2007 Device Drivers at the following location:
http://joule.ni.com/nidu/cds/view/p/id/849/lang/en

If you right-click on the attribute in Server Explorer and go to Properties, do you see anything that might be affecting the readings?  I have the data type on the settings tab to "Default", and the canonical data type is listed at 4-byte UInt.
0 Kudos
Message 4 of 6
(6,174 Views)

Devin-

I downloaded and installed the FieldPoint 6.0 update, and the problem is fixed.  The OPC executable did not change, so the trouble must have been with a component it used.

Thanks for your help.

0 Kudos
Message 5 of 6
(6,161 Views)
Rialto,

You're very welcome!  I'm glad you were able to get things working!
0 Kudos
Message 6 of 6
(6,139 Views)