FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

Field Point 5.0 support for 8.2.1 or 7.1

Highlighted
I installed Field Point 5.0 and sellected support for both 7.0 and 8.0. I am using Labview 7.1 and 8.2.1 at the moment. The Field Point libraries didn't show up for either version though.
0 Kudos
Message 1 of 8
(5,164 Views)
FieldPoint 5.0 does not have support for LabVIEW 8.2 or 8.2.1 because it shipped before LabVIEW 8.2 was released.  To get FieldPoint support for LV 8.2 or 8.2.1, you should install FieldPoint 5.0.1.

You should be able to install LabVIEW 7.1 support from the FieldPoint 5.0 CD, though.  You mentioned you only installed support for LabVIEW 7.0 and 8.0 from that installer - you should also install support for LabVIEW 7.1.

-Tommy
0 Kudos
Message 2 of 8
(5,144 Views)

Hi,

I had a similar problem: I had LabVIEW 8.0.1 on a computer and I ran 8.0.1 builds from another computer.  Then I loaded LV 8.2.1 on the computer and my old programs built with LV 8.0.1 couldn't talk to my Compact FieldPoint 1808 module.

I tried to load support for 8.0 when I installed LV 8.2.1.

I got my builds to work by copying a FPLVMgr.dll from the data folder of a newer build.

Is this OK?  Does anyone know what I could've done wrong?

Thanks,
Albert

0 Kudos
Message 3 of 8
(5,089 Views)
Hello Albert,

When you installed LabVIEW 8.2.1 and opened the file, it appears dependencies were created for that VI.  Did you "Save for Previous" in LabVIEW 8.2.1 to save the VI in the LabVIEW 8.0 format?

Also, what version of the firmware do you have installed on the 1808?

-Bob
Message 4 of 8
(5,071 Views)
I wasn't running the VI under 8.0; I was trying to run an existing .exe that I had built under 8.0 after I had installed 8.2.1 on the target computer.
 
My firmware is v6.01.
 
Thanks,
Albert
0 Kudos
Message 5 of 8
(5,059 Views)
Hello Albert,

I am curious, have you reinstalled or repaired the FieldPoint driver since installing LabVIEW 8.2.1?  When installing a new version of LabVIEW, you will need to reinstall or repair the drivers in order to add support for the new version of LabVIEW.  Please let me know if this fixes the issue or not.

-Bob
Message 6 of 8
(5,040 Views)

Hi,

The only installing that I did was installing LabVIEW 8.0.1 a while ago and then 8.2.1 recently.

The only repairing I've done was to manually replace a FPLVMgr.dll for a LabVIEW 8.0.1 build application with a version from a LabVIEW 8.2.1 application.  This fixed my problem but I'm not sure it's right.

I feel like I'm not explaining myself well.

LabVIEW 8.0.1 builds stopped communicating with my cFP-1808 after I installed LabVIEW 8.2.1.  This problem only occurred on the target computer and not on my development computer.

Thanks,
Albert

0 Kudos
Message 7 of 8
(5,021 Views)
Hello Albert,

Additionally, you would need to make sure the FieldPoint 5.0.1 driver and support for LabVIEW 8.2.1 are installed on the target computer.

-Bob
Message 8 of 8
(5,014 Views)