FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

Failed to connect to RT Engine


I'm trying to run the from Labview 7.1 on a cFP-2020 to access it's serial port (RS-232). Therefore, I need to change the execution target to the cFP but this produces an error (Failed to connect to RT Engine. Returning to target selection dialog), despite the facts
that I can successfully communicate with I/O-Modules that are connected to the cFP-2020 (RTD, AO, AI, DI),
that I can ping the cFP 
that I'm in the same subnet as the cFP
and that I can fully explore the I/O-modules in the MAX.

I have not reset the IP on the cFP due to the successful ping.

Thank you very much in advance for your help!
Dirk Winkelmann

0 Kudos
Message 1 of 4
Hi Dirk!
   I have LV 7.1 and a cFP-2020.  I open a project of mine, for real time target. After this, I open Basic Serial Write and, and I download it, and it executes fine.  So, what I can say is just connect to cFP-2020, with another project, and then open serial example.

   Anyway, since serial com is quite simple in cFP, you can just write a vi with basic instructions you find in the example, it'll work (I hope).

If you experience more troubles, please tell me, I can check, since we have the same HW/SW configuration.


0 Kudos
Message 2 of 4
Hello Graziano!

Thank you for your quick reply. I am an undergraduate student working this project and I am really not much into all of this electrical engineering and communication things. After spending all day yesterday to troubleshoot, I switched on the setup this morning and it worked fine. I guess a system reboot is a decent remedy again that.

Now encounter the next obstacle: I want to communicate with a Julabo Thermostatic Bath over my serial port on the cFP-2020, but I don't succeed in its confirguration. Actually, the MAX offers an option under "Devices and Interfaces" to configure Serial Connections. Yet, there's only the serial port of my computer listed. Down below at "Remote Systems", I don't have this option of serial port configuration.  So, how can I access my serial on the cFP? I looked at the Basic Tutorial CD 1, Excercise 8-6, which tries to establish communication over a serial port. Yet, in their confirguration dialog for the "Instrument I/O Assistant" I also lack the choice of my cFP serial.
(This is a quite general question but neither the manuals for the cFP not the VISA could help me on that... so, to avoid that you'd have to write a lenghty discussion, maybe you know a good site where it is described?)

Due to limitations in space and the lack of a cable, I can't connect the Julabo directly to my computer.

Thank you again for your help!!!
0 Kudos
Message 3 of 4
   As I said, I'm using serial port RS232  on my cFP-2020, to communicate with external instruments, and you don't have to configure it in MAX or something else.

   The serial port is quite simple to use, just you configure it depending on your needs, as you can see in the example, and then open it, and send data through it.  To configure I mean set baud rate, termination char, etc....

   Some things I need to know; first, you say you're an undergraduate: can I ask what is your major? This can help me understand what for you is simple instead of what are things maybe you don't know....

   Then, I suppose you have LV 7.1 and Real-Time module (if it isn't like this, you are unable to dowload applications to your cFP.  To access cFP's serials, you need an "embedded" appication, i.e. you need to work with the real-time target.)

   More: something about your instrument RS232 specifications, I mean the Julabo device, I hope it is a simple RS232 instrument, with a common asynch serial RS232.  If you can post the details of instrument, I will appreciate.

   Unfortunately, I don't know any sites (of course they will exiast!) in which your question are well explained.  Usually, the best place to learn is NI forum, and don't worry about people like me, spending time to answer: sometimes, questions can learn more than answers!.

Have a nice day!

0 Kudos
Message 4 of 4