FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

FP-2000 System State: Connected - No Software Installed. Firmware Error??

I have a FP-2000 module that I was in the process of configuring. Everything was going fine, my bank was detected properly etc. I had set the IP, rebooted the device and noticed that my timestamp was wrong when viewing some feedback from my temperature module. So I went to change the timezone on the FP-2000 module and it asked me to reboot for changes to take effect. After the reboot the status LED was blinking twice indicating a firmware upload error?? I was not trying to update any firmware on the module though.

How do I go about making sure that the correct firmware is installed on the module. I went to the add/remove programs and all the options are grayed out except for the custom software installation.

When I expand the software tree for the FP controller this is the software that it says I have installed:

Fieldpoint VI Manager 1.0.28

FieldPoint Watchdog 1.0.28

IA Control Environment 4.1.6

Labview RT 6.1.1

NI-Serial 2.0.2

What am I missing? 


I am not planning on putting embedded VI on themodule as I do not have the RT module pack and am simply planning on running a VI from my computer. The available software that I have listed in the custom menu is as follows:

Fieldpoint Drivers 6.0.0

Fieldpoint VI Manager 6.0.0

LabView PID control Tollkit 8.5

NI-IrDA RT 1.0.2

NI-Serial RT 3.3.0

NI-Visa 4.3

NI Watchdog 2.1.5


I simply don't want to install a set of software/firmware upgrades and render the module totally useless. Is there not an image of what NI sends out with its FP-2000's that I can upload onto the controller? I am running Windows XP, with LabView 8.5.1

0 Kudos
Message 1 of 4

Hi Plow,


The status light is indicating that there is an error with the firmware.  If you click on the Update BIOS button when you select add/remove software you can load the latest firmware for the device. 


Best Regards,

Bryan H.
0 Kudos
Message 2 of 4

ok so I went to update the BIOS. It replcaed the current BIOS on there which was 10.1 with 10.4.

Now when I look in MAX under software for that device, there is no software listed. I go to add/remove programs and all the recommended software sets are grayed out.

The only option is for me to go into custom install. From there I tried to install the following:

Datasocket for Labview Real-time 4.5.5

Fieldpoint drivers 6.0.0

Field point manager 6.0.0

Labview RT 7.0.0 (nothing newer listed)

NI serial-RT

NI Visa 4.4

NI Watchdog 2.1.5


When I try to install I get the folloing "error"

Cannot continue because the following unresolved dependencies:

NI Serial RT 3.3.3 requires Labview RT 7.1.1

Fieldpoint drivers 6.0.0 requires Labview RT 8.0

NI Visa 4.4 require Labview RT 7.1.1

Datasocket for labview RT 4.5.5 reqiore labview RT 8.6.0

MS visual studio7.1 Runtime support 2.0 requires base system 2.0

fieldpoint low-level  I/O driver 6.0.0 requires base system 2.0

Fieldpoint VI Manager requires labview RT 8.0

LogosXT 5.0.1 requires base system 1.0

Logos 5.0.1 requires base system 1.0


It seems as I can't install any software on this module? Why isn't the base system available as something I can install.

If I remove the Datasocket for Labview software from my list and downgrade all the versions to the earliest available for install I still get unable to install because I don't have Labview RT 7.1.1, base system 2.0 and base system 1.0

I found an image file for labview RT 7.1.1 installed as per the readme file and restarted MAX but RT 7.1.1 is still not available as a selectable software installation.

I would think there would be a driver / firmware download or an image file I could download to solve this problem but I can't find one, ideas? or is this an inherent problem with NI fieldpoint hardware that the firmware crashes and you are not able to update it?


0 Kudos
Message 3 of 4

Hi Plow,


You can still install software without having the Real-time Module.   This Knowdedgebase has instructions for doing it.


Best Regards,

Bryan H.
0 Kudos
Message 4 of 4