FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

Communication problem with FP-2000 and Labview 7.1

I am using the FP-2000, DO-403 and TC-120 modules with Labview 7.1, being run on a host computer via an ethernet connection.  The setup has operated flawlessly for ~2 years; recently, I have noticed that while a VI is running on my PC, connection to the FP module ceases.  There is no pop-up "connection error" in my VI, and the all the power and status LEDs on the FP modules are normal.  I can still interact with the VI on the front panel while it is running, but nothing is passed to the FP module.  I have tried communicating with MAX when this occurs and receive a "no connection" message.  Is there a simple solution here, such as rebooting the FP module?  Or is it time to invest in new hardware?
0 Kudos
Message 1 of 5
      Has anything about your system changed recently that might have caused this behavior?  Does the "no connection" message have an error code associated with it?  Rebooting the FP unit would not hurt.  Also, do you have another host computer to try the application on?  What software do you currently have on your host machine and on your FP 2000?


0 Kudos
Message 2 of 5

I am having a very similar problem with my cFP-1804 and Labview 7.0.  I have no problem initiating communication over ethernet, and the vi will run perfectly for hours or even days.  Inevitably, however, at some point there is no longer communication with the cFP-1804.  Data is no longer being passed either to or from the cFP-1804, and MAX will show that the device is not connected.  I also will not see any pop-up error message that says the connection has been lost, either from Windows or from Labview.  The vi will just continue to run as if nothing has happened.  Turning the power to the cFP-1804 off and then on will always resolve this problem.  Since I am using the cFP-1804 primarily for data logging, however, this behavior is particularly problematic as the system will record nothing but zeroes until I discover that the communication has been severed and perform the manual power cycling.

I have been unable thus far to determine the cause of this problem.  Any help would be greatly appreciated.



0 Kudos
Message 3 of 5

Initially, I would lose communication between my PC and FP module after a matter of minutes.  This turned out to be a problem with the IP address (another PC on the network must have been assigned my FP address) , and switching from static to dynamic in the settings solved it for the most part.  Perhaps you should investigate this, since turning the power off/on usually worked for me as well.  I still lose communication once in awhile, and need to hard-reset the the FP unit and basically reinstall it with MAX to restore communication; the problem is more manageable now, but I have still not discovered the cause.


0 Kudos
Message 4 of 5


Thanks for your response. 

My system is such that the cFP-1804 is connected to a single PC via a network hub.  These are the only two entities that exist on the network.  To be absolutely certain that there was no IP address conflict, I turned off the power to the cFP and tried pinging its IP address with the PC.  The response timed out.  When power was reapplied to the cFP and pinging was repeated, there was an immediate reply.

Perhaps something is causing my hub to drop the connection intermittently.  The only reason I am using a hub is because I did not have a crossover cable long enough to connect the cFP to the PC.  I will see what happens when I replace the hub and the two patch cables with a single crossover cable directly from the cFP to the PC.


0 Kudos
Message 5 of 5