FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

About compact field point & real time modules

Hi all,

 

Now, I design to buy a compact field point modules.

Does it support LV7.1? and which version of real time modules and compact field point do I need?

 

I knew there are software envioment inside the compact field point.

If the version inside the field point (e.g. 8.x )is higher than the developing program's labview(e.g. 7.1) one does it has problem ?

 

Thanks.

 

Regards,

Robert

 

 

0 Kudos
Message 1 of 5
(5,674 Views)

Hi!

   From datasheet, cFP-22xx family recommends LabView 8.5.1 or higher, and probably it is not possible to use LabView 7.1.  Consider that in these modules you have a new operating system (VxWorx), different from previous PharLap, so I guess LV RT 7.1 won't fit.

 

   On the opposite, cFP-20xx and cFP-21xx are compatible with LabView 7.1 (I'm currently using this gear), and if you buy a module with a higher LV RT version, you can re-install SW to cFP module.  I did it to downgrade cFP modules with RT 7.1.1 to 7.1.

 

  I hope this helps

 

graziano

0 Kudos
Message 2 of 5
(5,654 Views)

Hi,

 

I have cfp2220 and I only havw LV7.1. Do I have problem use this module and LV7.1?

I have a query how upload and download the code to cfp2220.

Now, I can only run on the PC side and through network cable, how to set it run offline and autorun?

 

Thanks.

0 Kudos
Message 3 of 5
(5,611 Views)

Hi!

   To run you application embedded, you need LabView AND LabView Real-Time module, of the same version.  I have LV 7.1 + LVRT 7.1, and I use them for cFP2020 and cFP2120;  so, have you the RT module?

 

   About cFP-2220, I think you are forced to upgrade to LV 8 or higher, but for this you'd better check with NI people, I don't have that hardware and I can't test it for LV 7.1, and I don't know if there's some work around for it!

 

   Maybe you can just try to dowload software (firmware, actually) on cFP-2220 with MAX, with the install software option.  But this is for cFP firmware, not for LabVIew code.  To download and run embedded LV code you need RT module.

 

Let me know if it wasn't clear, I've just tried to keep it simple...

 

graziano

0 Kudos
Message 4 of 5
(5,609 Views)

Hi,

The cFP-22x0 controllers require LabVIEW Real-Time 8.5.1 or newer because they use a different operating system (VxWorks) from the cFP-21x0 or cFP-20x0 controllers (Pharlap). You can run LabVIEW Real-Time 7.1 through 8.5.1 on the cFP-20x0 or the 21x0 controllers.

Eric A.
National Instruments
Distributed I/O Product Support Engineer
0 Kudos
Message 5 of 5
(5,591 Views)