FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

n00b qustion from AUS - new team

Go to solution



Noob here, sorry if this is not the forum for this question. We are starting a new team here in Toormina, NSW, Australia and I am coming in cold as a mentor. We are using labView and I have installed from our labView2017 CD as per the instructions here


Loading a prototype project the team had from the last Sydney event I am finding that all the project dependency VI libraries are missing (They do not exist in the install dir: D:\Program Files (x86)\National Instruments\LabVIEW 2017\vi.lib). This seems to indicate that the default DVD install does not include these VIs. Can anyone help with clues to troubleshoot? Extra steps I need to perform to get these standard VIs? How I search for pre-existing solutions, etc Please see attached file.

Thanks Darren 

0 Kudos
Message 1 of 4
Accepted by topic author DarrenG

Hey Darren,


Great question! It looks like you might need to install the FRC update suite as well which doesn't come on the disc and is distributed via the web.


Here are some instructions.


Installing the FRC Update Suite (All Languages) -


For most of these questions your best help are the following sites.


Getting Started with the Control System -


FRC Resource Hub -


Best of luck!

Application Engineer, RF and Communications
National Instruments
Message 2 of 4

Hi JY,


This worked fine I can now see the VIs!

You are a champion - thanks for the help.


0 Kudos
Message 3 of 4

Hey Darren,


Glad it worked! It's awesome that you're starting a team too! Best of luck next season.



Application Engineer, RF and Communications
National Instruments
0 Kudos
Message 4 of 4