FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

installation

Solved!
Go to solution
Highlighted

Can we reinstall the vision example vi only?

0 Kudos
Message 1 of 9
(519 Views)

Which vision example?

It might be quicker for someone to post it for you

Champion CLA Instructor

Making senseless computers do
intelligent real world things
is NOT easy. SO MAKE IT FUN!
0 Kudos
Message 2 of 9
(514 Views)

The vision vi has been deleted out of our project, when we go to the vision vi example it won't let us open it. I believe the mistake was made by modifying the example and overwriting it.

0 Kudos
Message 3 of 9
(512 Views)

Should there be a Vision vi at the bottom of this?

0 Kudos
Message 4 of 9
(495 Views)
Solution
Accepted by topic author andivwh
02-14-2019 07:12 AM

Here are my recommendations.

Look in your project for the  Vision Processing.vi

 

vision processing vi.png

If you can't find it then I would create a new roboRIO project and copy it over to the current project

new project.pngnew project 2.pngnew project 3.png

Champion CLA Instructor

Making senseless computers do
intelligent real world things
is NOT easy. SO MAKE IT FUN!
0 Kudos
Message 5 of 9
(491 Views)

Looking closer at the image you posted it looks like your main while loop has been deleted. The robot main without any modifications should look like this

main.pngmain 2.png

It also looks like your auto and test reference vis are broken. All these will have to be fixed before you can think about getting the vision to work.

Champion CLA Instructor

Making senseless computers do
intelligent real world things
is NOT easy. SO MAKE IT FUN!
0 Kudos
Message 6 of 9
(489 Views)

I am not sure why the screenshot does not show those loops, but they are there. Our robot main looks exactly as your images except, we have now dragged the Vision VI block into the robot main and wired it the same as the camera and timed tasks blocks. We still do not have what we want, but we are not giving up.

0 Kudos
Message 7 of 9
(481 Views)

Yes it is all still there. We opened the vision processing vi and drug the block  and placed the copy in the robot main.

0 Kudos
Message 8 of 9
(480 Views)

When we put the program on the robot with the Vision VI block wired in the robot main, this was the result:

  1. we had one camera view and not the other
  2. we switched the camera usb slots
  3. then we could not get anything
  4. we switched back and still had nothing
    However, we have a list of errors if that helps:
    1074360311
    1074360310
    1074360316
    1074360319
0 Kudos
Message 9 of 9
(479 Views)