FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

cRIO Issues


We are a fairly new team and have been having issues imaging our cRIO Device. When we open our imaging tool and scan, it recognizes our cRIO with an IP Adress of The cRIO switches are all grayed out and switched to the left. When we click "apply" after checking "format controller" it runs for about a minute and then the status window says "Unable to asign an IP Adress for the compactRIO device. Ensure the IP RESET switch on the compactRIO device is switched off." However, we cannot interact with any of the switches. We have a cRIO II so the switches are not actually on the device. We did all the steps in the instructions: We changed the computer's IP Adress to (our team is 4150) and the computer's subnet mask to We also went into NI MAX and tried to change the cRIO Device's IP Adress to and the subnet mask to but got an error as well. The whole issue arised when we tried to run the robot and the robot would not connect to the driver station. We then noticed that the STATUS light was blinking twice regularly. According to the cRIO handbook, this means that there is an issue with the code which probably occured during an update. What can we do? Any suggestions?

0 Kudos
Message 1 of 10


Try setting your computer to a 169.254.X.X ip address similar to what the imaging tool says the cRIO is at but change one of the X numbers. Doing this should allow the imaging tool to set the ip address. Then you'll need to reset your computers ip address back to and rerun the imaging tool to make sure all the software is installed.

Kyle Hartley
Senior Embedded Software Engineer

Message 2 of 10

Thanks for the suggestion Kyle. The team tried that previously and got the same result described above. Since the 169.254.x.x indicates a link local address, in MAX they also tried changing from DHCP to Static ip and received an error when trying to Save in MAX or selecting Reset in MAX.

0 Kudos
Message 3 of 10

Sounds like it might be a firewall issue or multiple NIC issue.  Disable any firewalls on your system and disable all but the NIC you are using to communicate with the cRIO. What errors do you get when you see the target in MAX?  What happens if you right click the target in MAX and select Format?

Kevin Fort
Principal Software Engineer
0 Kudos
Message 4 of 10

Thanks Kyle and Kevin! We tried your suggestions. We still got the error: "Unable to asign an IP Adress for the compactRIO device. Ensure the IP RESET switch on the compactRIO device is switched off." Our IT mentor ensured the connection from our computer to the cRIO is not the problem, ensuring windows firewall was completely disabled and the ethernet port was powered on (classmates turn off ethernet ports when not connected to a wall charger). The error arose with both IP addresses ( and We have not tried to format the cRIO yet, having run out of time at our last meeting. That's definitely next on our agenda. Any and all additional suggestions are appreciated, and we'll keep you updated as matters progress.

0 Kudos
Message 5 of 10

The Controller Settings tab in MAX will have virtual dip switches for putting the cRIO into safe mode. Are the check boxes in this tab greyed out as well? You might want to try pinging the cRIO at the IP address you expect it to have; it may not be showing the correct address in MAX.

Make sure the IP address of your computer is set to a 169.254.x.x address with a subnet mask when first connecting to the cRIO. This will put the PC on the same subnet as the cRIO and allow you to save new IP settings to the cRIO (moving it to address). Once the cRIO IP address is changed, you can then change your PC's IP address to match its new subnet (something like

The cRIO status light will blink twice when there is no software installed, so I don't think there is a software problem.

Zach P.

Staff Software Engineer | LabVIEW R&D | National Instruments
0 Kudos
Message 6 of 10

Thanks to all; we got past the communications issues and successfully reimaged the cRIO and can ping the DLink and robot.    Now we are troubleshooting the lack of the "DS Radio" led.  More in a bit....

0 Kudos
Message 7 of 10

I ran in to this during my Quick Build Session. Here is how I solved it (would love to see if it works for someone else):

1. Disable the wireless network card on the computer.

2. Manually set the IP of the wired network card to 10.xx.yy.5 (driverstation IP where xx.yy is your team number ie, Team 2341 would be

3. Close the 2014 FRC cRIO imaging tool

4. Open MAX and select Remote Systems (let it search for the cRIO, this took a few min)

5. Select the cRIO from the list

6. look through the tabs at the bottom until you find the switch settings specifically the one that says Reset IP. check it, save the settings, and then restart the cRIO

7. Once the cRIO restarts, go back and uncheck the "Reset IP", save the settings and restart the cRIO

8. Close MAX

9. After the cRIO Starts backup, open the 2014 FRC cRIO imaging tool and apply image as normal.

For the communication issues, for the drivers station, make sure your wireless network adapter is disabled (unless this is how you are communicating to the robot and if this is the case good luck!) and the IPs are correct for your router, Driverstation, and the cRIO. Verify that the correct Team number is in the 2014 Driver Station under the Setup tab and that your Robot Project had the correct IP/team number entered when it was created.

If all of that is correct you can directly connect your driverstation to the cRIO with a crossover cable and see if the software talks to the driverstation and then work back out to the router and bridge.

Also look at these resources: For the Router/Radio, Imaging your Classmate, Building and Loading your first LV Project, Imaging your cRIO

Good luck everyone!


0 Kudos
Message 8 of 10

Hi, could you share how you got your problem corrected.


0 Kudos
Message 9 of 10

Cleous, you've responded to a very old thread.  The last post before yours started off stating they were giving their solution.

It would help if you shared the issue you're running into so we have some context to work with.  What hardware are you using?  Which version of the FRC software are you using?  What behavior are you seeing?

0 Kudos
Message 10 of 10